Author Topic: FIXED - [Script] :80: FileIOError: Write failed  (Read 2162 times)

FIXED BY DELETING SHELF.LOCK FILE in Documents/Allegorithmic/Substance Painter/shelf

the shelf was not locked but i still had to delete the shelf.lock file. Hope this helps anyone else having this issue

Substance Painter version: 2017.4.2
Substance Source plugin version: 1.0.2 (Minimal API 1.0.6)

Error: [Script] :80: FileIOError: Write failed

Encounter type: After downloading any asset from the Source store. Error is encountered right after the download finishes and the asset never shows up in the shelf. Error continues to loop every second or so until the Painter is restarted. After restart asset doesn't show up in the shelf.

More details: Have more than 300 downloads available in asset store; Account is logged in properly; License is updated properly; Source store is logged in properly; can browse all assets and use store properly otherwise; Tried running as admin but that didn't make any difference; Tried multiple assets but still the same error; Re-downloaded fresh copy of latest Painter; Reinstalled latest Painter; Deleted source plugin folder; Reinstalled latest source plugin manually
Last Edit: January 26, 2018, 09:15:04 am

Try deleting the source plugin folder in your Documents/Allegorithmic/Substance Painter folder and restarting Substance Painter. This issue should be fixed with the plugin that comes with 2017.4.2

Fix in post 1

I just deleted the source plugin, downloaded a fresh zip and installed the source plugin manually back into 2017.4.2. Still having the exact same issue. Constantly looping [Script] :80: FileIOError: Write failed as soon as an asset download finishes.

Also manually importing .sbsar into the shelf is crashing the painter

Edit: Also deleted the source plugin folder in Documents/Allegorithmic/Substance Painter folder and relaunched painter. Still having the same issue
Edit 2: COMPLETELY re-downloaded a fresh copy of 2017.4.2 and reinstalled substance painter and the issue is still there... Please look into the fix again, i think you guys missed something

Last Edit: January 26, 2018, 09:13:31 am

Nevermind, I found this at the end of another rabbit hole. You have to do it manually if you are sticking with versions 2017.1 to 2017.3.... manual download and install instructions can be found here -

I am still getting this error. Tried deleting the entire Substance Painter folder under Documents/Allegorithmic/Substance Painter.

Anyone else have any other fixes?
Last Edit: February 25, 2018, 05:06:31 am