Author Topic: SP doesnt't load Smart material and texture export presets  (Read 3658 times)

Hello!
As from title...dunno what happend but every time i  open Subtance it doesn't load my smart material and textures preset export setting are missing...i see them in the relatives folders but not unable to get inside substance

In what path exactly did you put your assets?

C:\Users\myPc\Documents\Allegorithmic\Substance Painter\shelf

Inside the Smart-material folders i see my own material..but sp still not dispaly any

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

here's the log

Is "D:/Substance/Substance Painter/" your install path for Substance Painter?
It looks like the crawling of the default shelf in that folder never finishes, so it never switches to the shelf in your documents.
Can you make sure the folder is not read/write protected or could you try to install in a different folder?

In my case it was a similar problem and "run as administrator" for start of substance solved it sometimes.
Just another idea...

Is "D:/Substance/Substance Painter/" your install path for Substance Painter?
It looks like the crawling of the default shelf in that folder never finishes, so it never switches to the shelf in your documents.
Can you make sure the folder is not read/write protected or could you try to install in a different folder?

yep i installed SP in D:..  what  you mean with read/write protected? btw  all was ok till the last week, and i didnt change any

From what I see in your log file, the crawling of the ressources had started but not finished.
Could you try again and wait, let say an hour, and attach a log file again ? Just to see how long the crawling takes. If you can do it with Substance Painter 2017.4.2 as well this will be helpful, as we have more debug information regarding the shelf printed in the log in this version.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

the materials  were uploaded  (i didn't watched the whole time)  in 5-10 minutes..btw during this time Sp was super slow and unable to do others operations...after the materials showed up i still having trouble of performances/freezing/slowing

no way to fix this?

The log indicates that your shelf crawling time was around 50s. For the first time loading Substance Painter 2017.4.2 this is expected as we update the resources, next launch should be faster to proceed.

Could you check you don't have any software that could go in conflict with the application ? See : https://support.allegorithmic.com/documentation/display/SPDOC/Software+conflicts
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

nothing about those programs...still getting lag/freeze after smart material shelf loading

do i have to put up this post every week? or can i get some solution or even some section where i can easly find my post?

Hi Ivan,

I investigate you issue.
Could you try to update your GPU Driver and see if that fix the problem ?

Regards,
QA Analyst and Technical Artist at Allegorithmic