Author Topic: Trouble downloading materials from substance source into painter  (Read 3054 times)

Hi there,

I am suddenly having trouble downloading materials from substance source into substance painter. I still have lots of available downloads on source and even ones already owned will not install. When I try, I get error messages like below in the substance painter log window. I have tried uninstalling substance painter and reinstalling, but the error has continued. Do you have any suggestions what might be wrong and how to try and fix it? It was working fine a few days ago so not really sure whats happened.

- Jim

[Script] :28: ResourcesError: Preload of C:/Users/Jim/Documents/Allegorithmic/Substance Painter/plugins/substance-source/Temp/roof_steel_panel.sbsar failed. Doesn't point to a valid resource.
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed


Having the same problem. Uninstalled/Reinstalled, tried "run as admin", and still didn't work. Also creates a similar error on saving a file sometimes, but the file still saves.

I have noticed that going to the Substance Source web page and download/drag and drop into SP still works.

We are looking into it, thanks for the report!

Hello, any fix for that ?

I have this same errors:

[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed

Please help!
Last Edit: January 10, 2018, 07:50:03 am

I am having this problem as well. 

Also, while you are fixing that Allegorithmic, can you also make it so that the source inside my app can be told to remember my password so I dont have to type it in each time?  I know the app remembers my pw because it renews itself each month from my subscription.

There is also an issue on the windows version where sometimes when the source window is minimized it refuses to maximize again.  It doesnt happen all the time, but if it is clicked, or the app quits and runs again this window should auto max so you can see it.

It would also (given this issue) be nice if there was some sort of SYNC functionality where I could tell the app to check that all of my owned Allegorithmic textures are installed in my app.  I have found that after reinstalling after a windows issue, I seem to have lost some of my textures and it is a PITA to try to figure out if all are there or not.
Last Edit: January 13, 2018, 03:01:21 pm

[Plugin - substance-source] Downloading Cliff Stylized Mossy...
[Plugin - substance-source] Asset rock_cliff_stylized_mossy.sbsar Downloaded from Source, now transferring to shelf
[Script] :28: ResourcesError: Preload of C:/Users/Name/Documents/Allegorithmic/Substance Painter/plugins/substance-source/Temp/rock_cliff_stylized_mossy.sbsar failed. Doesn't point to a valid resource.
[Script] :80: FileIOError: Write failed
[Script] :80: FileIOError: Write failed

It was working. Just spams [Script] :80: FileIOError: Write failed

It ends up in the Temp file, but dragging it into the Material folder does not seem to work either.
thank you.


Just wanted to report the same error over here.

Thanks!

Yes, a change on the server side broke the plugin.
A new update to Painter and to the plugins will be released beggining of next week.

This was posted in another thread. I assume it will be working after the 15th sometime.

My thought is, don't change the server until the update is ready. I know, crazy thinking.