Author Topic: Points and older SD/SP Versions  (Read 460 times)

hi there,

I got SD 5.x and SP 2017.3.3 as my latest versions and also plenty of points left to spent on items on the source website. Now - will ALL items on this site work with my SD/SP versions? How can I make sure, before spending points, only to see that things might not be working / not combatible?

kind Regards

Everything will work fine with Substance Painter.
You will likely won't be able to open some of these substances in SD 5.x though since they were created using SD 6.x