Author Topic: Substance plugin for UE4.3 and above setup error  (Read 2869 times)

Hi

I get following error when trying to install plugin from:
http://www.allegorithmic.com/substance-ue4


I simply make a new project of version 4.3 and copy over the plugin files from the download.
I have tried to put the plugin both in the project folder and directly into the engine (4.3/Engine/Plugins).
I have also tried following steps:
Hi Steve, let me know if these steps work for you:

1. Do you have C++ Source code in your UE4 project? If so, load your solution file in Visual Studio and proceed to step 7, otherwise keep reading:

2. Load your project in the UE4 Editor
3. Click File -> Add Code to Project
4. Leave "None" Selected and click Next.
5. Leave the fields at default and click Create Class.
6. Click yes when asked if you'd like to edit the code now.

7. Make sure your project configuration is set to "Development."
8. Click Build->Build Solution and wait for your project to compile. It should also compile in the substance library.
9. Close Visual Studio and Reopen your project in the UE4 Editor
10. Click Launch

I know it's more than a few steps, but let me know how it goes!

After a clean install of 4.3 the problem was solved

Glad to hear aa.andersson!

Hi, i experienced and still experience the same error.
(I use this topic so i don't waste the forum creating a new one)

I was at first using the build from Source code. So i was getting this error, then i tried the solution given, and it fixed it... for one boot. Then the other times it displayed me that my game modules were out of date and need to be recompiled.
I tried both Yes or No, but it fails.
So now i use the Engine from the laucher, i still get the error, and on top of that, the editor won't launch at all (until i remove the plugin from my project). So i can't even "add code to project" fonction anymore....
I'm used UE 4.3, 4.3.1 and 4.4, and none of them works. In the best case, the editor is ok to boot, i can see the plugin in the plugin manager, but when i try to import an .sbs or .sbsar, i get the "unknow extension" message.

It's really driving me crazy :'(

EDIT:
Ok my bad... my substance was simply corrupted... working fine in 4.3.1
Last Edit: August 05, 2014, 04:00:46 pm

Getting this error when trying to load in a Substance.

Failed to import 'T:/Art/Projects/substance_shader_library/SUBSTANCE DESIGNER/black_rubber.sbsar'. Failed to create asset '/Game/Materials/black_rubber'

I'm not sure if my build is set to development or not and after reading the UE4 documentation on changing the build type I'm still confused.

Edit2: Never mind, my build is on development and I am using UE 4.3. Installed the plugin to my project, which shows up in the engine under plugins.
Last Edit: August 07, 2014, 09:58:49 pm
Chris Stone
Weapons Artist @ Treyarch