Author Topic: [SOLVED] Substance Designer Crashes on Creating new graph  (Read 1345 times)

Hi,
The Software that I am running on a student license crashes as soon as I attempt to create a new graph. I have attached a log file if it helps in any way.

Thanks
Last Edit: January 21, 2020, 11:44:09 am

Hi,

Your graphic card drivers are not up to date.
Update them and try to create a new graph.
Does it work ?
If not, come back to me ! (and send me your log file again, I need to see if you have the same error after updating)

You experience this problem on your personal computer or on a computer at your school ?
Do you try to work on Designer using remote session ?

Thanks !
 
QA Analyst

Hi, I actually have a similar problem, Substance Designer crashes when I open a new graph.
My drivers are updated and my substance designer software as well. I tried to delete 3d view file in regedit and that didn't work.

Thanks

more info
window 10,  64
nvidia 630m, core i7

Hi samuelmoquin,

Can you send me your log file, please ?
In the top menu of Designer, go into Help ->export log file.

Thanks
QA Analyst

Here it is.

Hi,

I sent you a PM !

For users who will read this, this is probably a driver problem.
If you have the same problem as Samuel, check if your graphic card drivers are up to date.
QA Analyst

I am having the same issue, Designer launches fine, UI works, but as soon as I try to create a new material if freezes.

I am also experiencing this issue. The program crashes upon creation of a new graph, but it doesn't crash upon opening or editing old graphs.
I'm running on a student license in Designer 2019.1.1, however, the issue persists in the latest release also.

The issue is independent of the graphics driver, as I've installed the newest edition of the NVIDIA drivers (both game ready and studio) and this hasn't fixed the problem
I've tried deleting the view3d registry key as suggested in this post: https://forum.substance3d.com/index.php?topic=8935.0, sadly this doesn't help either

Substance Designer log is attached
Additional hardware information according to the DirectX diagnostic tool:
Windows 10 (64 bit)
Geforce GTX 1060 6gb
AMD Ryzen 5 1600x Six-core processor (12cpus), ~3.6ghz
Last Edit: January 13, 2020, 05:38:51 am

Hello,

Thank you for reaching out to us with this issue. A crash/freeze when creating a material is often consistent with an issue with the initialisation of the 3D View, which occurs when the material workspace is being set up.

Therefore, in order to eliminate this as the possible cause for the crash, please take the following steps on Windows similarly to what was recommended in the thread mentioned above:
  • Close Substance Designer;
  • Press the 'Windows + R' keys;
  • Type 'regedit' and press 'Enter';
  • Select 'Yes' on the system prompt that appears to open the Windows Registry Editor;
  • In the address bar at the top of the window, paste the following address:
Computer\HKEY_CURRENT_USER\Software\Allegorithmic\Substance Designer
  • In the left panel folder hierarchy, select the 'Substance Designer' folder and delete it;
  • Disconnect the second monitor from your system, and connect it back (ignore this step if you do not have multiple displays attached);
  • Go to the following location:
C:\Users\<user>\AppData\Local\Allegorithmic\Substance Designer
  • Find a file with the *.SBSSCN extension and either rename, move or delete it;
  • Open Substance Designer, but do not create or open any project;
  • In the top bar, select the 'Windows' > 'New 3D View' menu item;
  • Check that the 3D View is correctly initialised, and try different preview meshes in the 'Scene' menu of the panel top bar;
  • Create or open a material.
Please get back to us with the results of following these steps, and we will reassess the issue at that time.

Thank you for your help and patience!
QA Analyst
Substance Designer Team

Hi,

The issue seems to have been fixed after going through the advice you set out, however not sure which step it was that solved it.

Either way, thanks for the assistance.

I just had this same issue and the solution fixed it for me.  I did not have a .SBSSCN in the Substance Designer AppData folder but it worked anyway.