Author Topic: From SP to Unity HD Render Pipeline  (Read 2996 times)

Hi, I'm trying to apply some textures exported from substance painter into unitys hd render pipeline shader but there's an issue with them, seems like they don't align properly.

Are the sizes wrong or what's going on here?
Thanks!





Update:

Seems like the uv map gets broken after being imported to substance. If I directly open the exported object in substance painter the uv map is correct, but if I import the object into unity and then open it with the plugin it gets completely broken..

Before plugin:



After being opened in unity with substance plugin via the "send to substance painter" option:

Last Edit: June 02, 2018, 06:59:00 pm

Hi, I'm trying to apply some textures exported from substance painter into unitys hd render pipeline shader but there's an issue with them, seems like they don't align properly.

Are the sizes wrong or what's going on here?
Thanks!



Update:

Seems like the uv map gets broken after being imported to substance. If I directly open the exported object in substance painter the uv map is correct, but if I import the object into unity and then open it with the plugin it gets completely broken..

Before plugin:



After being opened in unity with substance plugin via the "send to substance painter" option:



Does the mesh have multiple materials or multiple mesh parts? We have a limitation currently with multiple materials / mesh parts and it will only send textures from the first texture set. It looks like this could be the case you are seeing here.

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja