Author Topic: 3Ds Max 2018 plugin bake outputs not stable and couldn't find Substance Menu  (Read 2665 times)


The new substance2 plugin for 3Ds Max 2018 is really fantastic, I've been playing with it so far but I noticed something wrong with bake outputs...

I have a GeForce GTX 1060, so it always come to me up to 8K baking resolution, but when I try to bake at for example 2K it works great at the first time. however, when I try to bake at 4K in the next time I still got maps with 2K resolution instead of 4K!!! I have to re-bake again couple of times to get 4K maps and so on...

the second thing, I couldn't get my substance menu up there in 3Ds Max, I don't know why, I even go to Customize>Customize User Interface>Menus
but still couldn't find it there, because it's the only way to do substance to VRay, right?

Thank you so much again for this great plugin

Hey hus.benyahya,

I have noticed this occurring too. When you switch to 4k and 8k, are you switching then quickly clicking the Bake Outputs button? If this is the case, then the maps have not yet updated to 8k.

Improvements are coming to this system, but there is a 'workaround'. After switching a substance to 4k or 8k, make sure that there is nothing in the Render Queue in the bottom left corner of the Material Editor. The time to wait for the maps to reprocess might differ depending on the complexity and size of the substance.

For the second issue, is the Substance menu just not appearing when 3DS Max is opened? Are you using a custom workspace or another standard workspace layout? Looking at it now, the Substance menu only appears in the Default workspace. I'll make note of this issue.

Hello Keston
Thank you for your reply...

well, I've been playing around since that day and I've found the response of changing resolution isn't the main case, I gave it some time when I try to change from 4K to 2K but still not changing when I bake them out.
also, sometimes base color or diffuse turn to be totally black when I bake them out as well as the normal map, it happens but not quit often.

for the Substance Menu, I did change work space to default standard layout but still couldn't manage to show it off... I look at it in the customize but nothing in there as well!

Just confirming that I do not get the 'Substance' menu item either. Even if I go to the 'Default' workspace, I still don't have access to it. I also don't have any of the subitems that populate it. It's as if it's not installed or is not getting picked up when Max starts.

I reinstalled the Max Plugin but still no go. Because of this I don't have access the the GPU, CPU and memory options, etc.

I also wanted to mention, that I do not have Max installed to the default path on the C:drive. I have it installed on another physical drive. 
3ds Max Design (Max 2018/Max 2019), ASUS Z10PE-D8WS Motherboard, Xeon E5-2650-V3 Dual Processor, Dual Hydro H80i CPU Chiller, 64GB DDR4 Ram, Quadro K5200 Display Adapter.