Author Topic: Is your TDR being ignored ? I solved mine.. stop in and have a read. [Windows]  (Read 10438 times)

D3V


Let's dive right in.     
Basically, we're putting in registry keys that may have been previously assumed by the system or forced by the program/GPU drivers..so we're setting these keys to ensure they are handled and not ignored for whatever magical reason Windows10 is finding to be more of a hot mess.

WHY post this ??
• I saw too many posts about this..I decided to see what was happening. AKA: searched Nvidia/MS/Alleg. I only read what was hyper-important to a resolve.



IMPORTANT:
  (refer to the "sources" link at the bottom of this post)
STEPS..
1. Follow Alleg's docs on TDR settings...and then come back here to follow the next steps in the same manner/way/form/method/etc etc.

▼▼ In the same 'way/method/steps/etc' stated in the Docs linked above..AND in that same Reg-folder: ▼▼
2.
ADD: Reg_Dword  "TdrLevel"
edit this value to a 'decimal' input of 0 (ZERO). (refer to link at bottom for more info)

3.
ADD: Reg_Dword  "TdrLimitTime"
edit this value to a 'decimal' input of 60 (which is default - refer to link at bottom for more info)

4.
ADD: Reg_Dword  "TdrLimitCount"
edit this value to a 'decimal' input of  5 (which is default - refer to link at bottom for more info)

5. Restart your system *AFTER* you verify that everything you did to be 100% correct.
Note to Novices: Editing the registry incorrectly or with willful ignorant arrogance...can cause massive issues up to your system becoming unusable. ..plus it could grow bird wings and fly out the window.


..Now..after Windows boots, start Painter.


Sources:
MS Docs - TDR Reg Keys


• You follow this at your own risk
• I only run Painter on Nvidia GPUs .. and I have none of that Optimus-poop on any of my systems.
Not sure if ATI/AMD GPUs are having the same issue..perhaps this is a blanket-fix.

►► If this works for you, reply here and let everyone know so that others can know it works (at least for now).


Obligatory image:


Details from my end;

Nvidia GTX Driver 388.13, Painter 2017.3.   Windows10 x64 v1709 clean install
 *This Tdr issue existed in Windows10 x64 v1703 with Painter 2017.x, several months ago.  I assumed a clean Windows install would alleviate the problem, I was wrong.



Last Edit: November 11, 2017, 01:12:12 am

These might help out with my painter hanging and slowing down. Maybe.. Tnx

Quote
▼▼ In the same 'way/method/steps/etc' stated in the Docs linked above..AND in that same Reg-folder: ▼▼
• 2.
ADD: Reg_Dword  "TdrLevel"
edit this value to a 'decimal' input of 0 (ZERO). (refer to link at bottom for more info)
This actually a bad advice and something we don't recommend.
Disabling completely the Tdr detection means a GPU Drivers freeze could lock up your computer and lead to additional issues (corrupted files or worse). It's better to raise the Tdr trigger delay instead, like we suggest in the documentation.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

D3V


// update:  Nov.2018
this thread should be ignored..  Why ?
The Alleg team fixed the issue(s) at some point.
--
AKA: I would ignore this entire page unless you're left with nothing else to try. (which is where I was when I wrote this,.. there was nothign else I could do at that time).
If your system ever does stall out due to the Level "0"setting..I would hope that you're smart enough to avoid corruption.
-- if not: try at your own risk:
win+ctrl+shift+B = Restart Graphics Driver in Win10. The screen flickers and goes black for a second, and will be back in less than a second  Shortcut DETAILS at this LINK

Last Edit: November 25, 2018, 01:04:09 am