Author Topic: Substance Painter not running on the right hardware?  (Read 934 times)

So I own a desktop computer and had been using Substance Painter on it for a while, then all of a sudden I started getting this error pop up:

https://imgur.com/OaB2ZtZ

So I googled the error and sure enough a lot of others had the same problem, so I followed the steps to fix it. The first step was to go to NVIDIA control panel and go under the "Desktop" tab and check the box that allows the right click on the program to choose what hardware to run it on, but for me the option just isn't there.

Then the next was to go to the 3D settings and change the preferred processes to use, but I also don't have this option, these are the options I can change below:

https://imgur.com/N6pvcqP
https://imgur.com/HSCWoI5

I'm not sure what else to try, my graphics card driver is updated and my substance painter is all updated.

Any help would be much appreciated.

Are you not able to disable it in the device manager? Been a while since I've used Windows but I thought you were able to do so.

Your screenshots look blurry. Are you trying to make it not run on Intel graphics? Hard to tell you how cause to many steps ,but when you are in Nvidia control panel you need on “Program Settings” not “Global Settings”. You then can choose which graphics for Substance Painter.

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.