Author Topic: no object detected to attach a new mesh instance  (Read 7068 times)

Hello
 I have this little message appears whenever I open any objects in Substance Painter 1017.3:
"no object detected to attach a new mesh instance"

I tried several meshes with different objects but the same thing happened and I wonder why???

here's an attachment for that message

Could you attach an example mesh ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

here's a very simple one... this message appear with all objects I imported into substance painter, not only this on...

Thank you for quick reply.
Last Edit: October 25, 2017, 08:19:11 pm

Same thing is happening to me. Did you managed to get rid of it ?

Nope ! No answer and no fixing of the problem... i'm having the same problem 4 months later the first post.
I'm not able to open even the simples meshes that run in all other professionals programs and is definitely a bug because most of times the program menage to read the mesh but after some minutes it crush in this - Error line -
But if it could open and read the mesh few minutes before why suddenly the mesh is not attach?
I'm not here to criticize, just looking for solution, please give us some answer or a workflow than allow us to avoid this problem.
 

Hi guys,

This log (Error) is related to the fact that the mtl file is missing.
There is no big issue, and this error doesn't compromise your projects.

If you really want to remove this message from your log, please open your .obj file with a text editor and add "g default" just below these lines:
mtllib "obj name".mtl
mtllib "material name"   
g default

Here is an example done on the obj file provided by hus.benyahya
# author: headus 3D tools
#  using: ply2obj v1.8
#   from: uvlayout v2.09.04
mtllib Toy_Edit.mtl
mtllib Wooden
g default
# 6818 vertices
v 0.00000 1.49000 -37.52300
v -18.76150 1.49000 -32.49591
v -32.49590 1.49000 -18.76150
v -37.52300 1.49000 0.00000
v -32.49590 1.49000 18.76150
v -18.76150 1.49000 32.49590

Regards,
QA Analyst and Technical Artist at Allegorithmic

Hi there,
actually there is a major issue with this error message, at least with the latest Substance Painter release 2020.2.1. (6.2.1)
If the mtl file is missing the Mesh maps menu is not available in the Texture Set Settings window.

I've exported obj from Zbrush and imported it to Substance Painter and couldn't figure out why there is nothing except the document size in General Properties in the Texture Set Settings Menu. I had the error message described below. After editing the obj as you suggested the menu came back.

Regards,
Jarka

I am having the same issue, it doesnt allow to bake because there is nothing in texture settings. I have mtl  file though, not sure why it gives the error and why i can not see anything in texture settings.
which text editor we will use to edit?