Author Topic: Baked normal maps have hard edges  (Read 7893 times)

Hi,

I'm very new to both Substance Painter and 3D modelling/texturing in general, so I might not have been searching using the right terminology when looking for existing questions.

I'm trying to bake a texture in Substance Painter with a high and low poly model. The problem I'm having is that "edges" are really obvious on the baked normals, when I would expect them to be smooth. Here is the issue I'm experiencing with a simple sphere:

The edges from the low poly mesh are really obvious, when I would expect the whole thing to be smooth.



If you look at the normal map you can see where it is has sharp edges.


The low polly model looks like this


I've tried a number of bake settings, changing several of the values to no avail


What am I doing wrong here? Any help would be greatly appreciated.
Last Edit: October 16, 2017, 12:42:18 pm

Your low poly model seems to have hard edges for every polygon. You need to fix this in an external application before you import it into Painter. You need to smooth the normals, process works differently depending on the application.

Where did you create the low poly model?

I created the models in Blender and exported to .fbx

Perhaps the issue is there in that case. For the example above I have not marked any edges as hard specifically. Just Create mesh -> uv sphere and I used a different number of segments for the low and high poly models.

My actual models are obviously more complex, but I'm clearly misunderstanding something fundamental as it happens on a simple sphere too.

You need to smooth the vertex normals of your object (or define hard/ smooth edges for a more complex model) and make sure this info is exported correctly (there might be specific options you need to activate in the export plugins).

I have no idea how this is done in Blender unfortunately since I have never used that app. I use Modo, there is a specific integrated toolset for this task. Smoothing groups and tangent basis need to be exported with the FBX files to make sure the model imports correctly into Painter.
Last Edit: October 16, 2017, 02:02:51 pm

Thanks for the reply, it's really helpful. I'll have a play with that and update with an answer when I've got it working.

It looks like using "smooth shading" from within Blender (as opposed to the default flat) fixes this on the sphere, but I'll have a play with more complex models.

So for more complicated models it seems best to use smooth shading, but making sure to set certain edges as sharp. This can be mostly automated with the edge split modifier.

As soon as I changed these settings within Blender Substance Painter starts to bake in the way I would expect it to.

Thanks for the help volker.