Author Topic: Broken "cage" baking in 2017.3  (Read 2114 times)

Baking is broken. After updating to 2017.3 when I use the "cage" then I have totally broken. Previously it was good (I used the same settings, and the same mesh):

Please attach a log file :

Also attach a screenshot of your baking settings.
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I can confirm this problem too in Substance Painter 2017.3.0. I loaded up old successfully baked meshes and now substance painter completely breaks the baking with cage. Settings are not the problem. Log file attached below.
Last Edit: October 05, 2017, 11:02:41 am

I also think that something is wrong with the cage in the latest version of SP.
The last version I used before switching to the 2017.3.0 was 2.6.1 and it worked fine.
I installed the latest version yesterday and I tried to bake a very simple normal map using the settings I used in the 2.6.1 version but it didn't work.(Picture 1).
I changed the Max Frontal and Max Rear Distance a little bit, something I hadn't done before. I thought that it was ok after baking but I was wrong (Picture 2). In the iRay viewer it looks to me as if there was no cage used during the baking process (Picture 3).

Yes, we reproduced the issue and it seems to be a regression with 2017.3, we are looking at fixing it asap.