Author Topic: Can't seem to be able to set the $output size when using sbsrender  (Read 2756 times)

Hello, everyone.

First post here. Before I continue, let me just say that I am really enjoying the toolset you guys have created. Really fantastic work.

I am trying to use the automation toolkit to create a pipeline step which post-processes some textures. Regretably I have not been able to figure out a way to set the $outputsize variable through the command line.

This is the command im using:

Code: [Select]
sbsrender render  --inputs  dilate.sbsar --set-entry sourceData@sampleimage.png --set-value $outputsize@2,2 --output-path ./results --output-name sampleimage_dilated.png
The file has the single input color output size set to "Parent x 1". All other nodes are set to "Input x 1"

At the moment the output is always 256x25x which is the default in the sbsar file. I was expecting to get at 1024x1024 image.

Any help is greatly appreciated.

Rudy Cortes
LinkedIn

Thanks for your kind words about our product.

It might be related to the shell somehow interpreting the $ sign in the variable name
If using powershell try replacing the string $outputsize@2,2 with '$outputsize@2,2'

There are also some additional information about outputsize here:
https://support.allegorithmic.com/documentation/display/SAT/Frequently+asked+Questions

Let me know if this solves your issue


Yes! Tha was exactly the issue. I am using a mac and it is working like a charm.

Thanks for your help

Excellent.

Thanks for letting us know.
Another to mention is if scripting your command line calls in python using the subprocess module it will automatically quote the command lines correctly for the platform you run on.