Author Topic: Flat material issue  (Read 2018 times)

First of all, thanks for this amazing software and the way you care about the artists (supports, update, price system, students discount, etc.) :)

I have an issue with normals or maybe height in SD. At first I though I did something wrong with when playing with node, but I opened a .sbs from the tutorial and I'm having the same issue, my material looks flat comparing to the expected result. So I wonder if its something about the 3Dview settings or maybe tessellation? (I have a mac, with MacOS Sierra, so having Metal it should be fine, but maybe I am wrong).

Thank you in advance!

Bonjour, :)

Tout d'abord merci pour ce superbe software, ainsi que de la manière dont vous traitez les artistes qui l'utilisent (que cela soit pour les nombreux tutoriels, mise-à-jours, le système de prix, la prise en compte des étudiants, etc.)

J'ai actuellement un soucis possiblement lié à la gestion des normal maps ou height map sur SD. En premier lieu, je pensais que je m'y prenais mal avec les nodes, mais lorsque j'ai ouvert le fichier .sbs du tutoriel le problème a persisté, mon matériel semble plat en comparaison du résultat escompté. De ce fait, je me demande si cela à un rapport avec les réglages de la fenêtre 3D view, ou encore de la tessellation qui semble poser problème sur Mac (bien que je possède MacOS Sierra et que, de ce fait, je devrais avoir Métal).

Je vous remercie par avance,



There are 2 kinds of shaders in SD that give this kind of depth: Parallax occlusion and tesselation.
By default you're using Parallax occlusion, but you don't see the depth, because you have to turn up the 'scale' value in your 3D view settings.
To do this, in the menu of your 3D View, go to Material > Default > Edit, and increase 'scale'
You can enter a value higher then 1 by double clicking the slider and entering a value manually.

Tesellation can look a bit better, since it allows stuff to stick out from the surface of your model, but it can also be pretty resource demanding. The example you're showing is using tessellation.
To use tessellation instead of parallax, go to Materials > Default > Definitions > Physically.. > Tessellation

You may have to increase 'scale' again, and also increase the 'Tessellation Factor'. This will rapidly increase the polycount of whatever model is in the viewport, so don't turn it all the way up, since this can cause some serious slowdowns/crashes.


Thanks for your answer Eggfruit :)
I already tried to increase the scale, but I have a strange result with the Parallax occlusion shader. The edges of the entity (for exemple a plane here) do not move when changing the squale, and act like a mirror.
About tessellation, I think I can't use it on Mac, even if I have the API Metal.
Last Edit: September 23, 2017, 05:57:10 pm

Parallax occlusion always does that, sadly. It's because it doesn't actually change the 3d model like tessellation does. Instead it moves the pixels of your texture around so that it looks 3d from your perspective, but on the edges of the model that illusion kind of falls apart.

I didn't know tessellation didn't work on mac. Maybe it has something to do with the video card. Try to switch designer to the cpu engine under Tools>Switch Engine, then select SSE2. This does limit your texture resolutions to a max of 2048 though, in case that's an issue. (But you can always switch back to the other one, it won't damage anything)

Thanks again for your reply Eggfruit! :)

I tried to switch the engine but got the same issue with SSE2, but I actually find out that that Metal isn't in the Engine's list.
I just saw here that it is not supported.
Then, it will be a bit more complicated to work in SD because I can't see the result with tessellation! but at least when I export my SD material to an other application that support Metal I can see the tessellation I guess.

Have a good day/night!


Ah, that's to bad then.
And a good day to you too! :)