Author Topic: Export only base colour of a single Layer?  (Read 649 times)

Hey guys, new to SP. I've searched around and people have hinted that it's possible but I can't quite work it out.

Say I have made a layer that is specifically for my decals (in this case a red logo). How do I go about exporting just the base colour of that decal layer to a .png?

Thanks for any help.

I wondered about this the other day. The only way I know you could do it is create a export preset that would just export that layer.

I'm not sure how to individually select a single layer to be exported, so my workaround was to turn off the visibility of my other layers leaving only the decal layer active and then use a custom export to only export base colour. If there is a better way please let me know.

My issue now is when I try to export with transparency my UV islands are filled grey (while the rest is transparent), but essentially I only want the decals opaque and the rest of the image transparent.

I'm not sure how to individually select a single layer to be exported, so my workaround was to turn off the visibility of my other layers leaving only the decal layer active and then use a custom export to only export base colour. If there is a better way please let me know.
That's only possible via scripting currently.

For the alpha, check your export settings.
See the padding parameters here : https://support.allegorithmic.com/documentation/display/SPDOC/Exporting+textures
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Hey, yeah I did read up on the padding options and used Dilation+Transparent. Here are my setting and the result:

Config:
>

Export Settings:


Result:


As you can see, my UV islands are filled grey whilst I would like only the brush stroke to be opaque. The decal is on its own layer with only the stroke applied and the area around it transparent. I have no other layers enabled so the islands theoretically should be transparent. Any ideas?

I figured this out. Had to export like 100 times, lol. For a small test try this. Make a fill layer with only base color and emissive enabled, make sure emissive color is set to black. Add a black mask and make your decal. Keep your export settings the same ,but replace your opacity with emissive and set it to use alpha. This should give you a completely transparent image except your decal. There may be other ways ,but this seems to work.

Here's some pics.

I just tested again with opacity and it works the same as emissive.

Thanks! I knew it couldn't be too difficult lol.