Author Topic: Layer filtering on imported bitmaps causing seams  (Read 1682 times)

I have a serious problem with the filtering of imported bitmaps in fill layers.  I noticed this at first when importing base color images that I had to export to Mudbox to properly seam, since painter does not fully support UDIM's.   In the course of investigating that issue I noticed something even worse.  I wanted to add some height to some blood on my model, so I used a mask and the height channel to create it.  In order to have the blood override the base normal map I needed to load it into a fill layer, since "replace" will not work with a map loaded in the "additional maps" normal slot.  By doing this, filtering ruins the seams on all the maps. 

On the right you will see the normal maps as exported from Zbrush.  When they are plugged into the "additional maps" slot they look the same.  As soon as they are added to a fill layer however, the seams wind up looking like the image on the left.  Changing the type of filtering seems to have no effect whatsoever. 


There seems to be no way to turn off filtering for a fill layer.  Is there any way to fix this?  Any help would be appreciated.  I am using version 2017.1.0 build 1661.  Thanks.

This looks more like an offset than a filtering issue. Are you sure the fill layer has its scale set to 1 and its offset to 0?

I just opened the project to double check.  There is no offset and the scale is definitely set to 1.  That did however make me look closer at all the settings.  I found the issue.  The normal map is in gl format.  I tried setting the color space on the fill to OpenGL Normal and it fixed the seam issue on the normals.  Even though the project is set to have an OpenGL format in the project configuration settings, the auto color space was not interpreting the bitmap correctly.

Thanks for the reply.  I probably would have never noticed the solution if I hadn't gone to check all the settings again.

Ha indeed it's a known issue we plan to fix: normal maps imported in a project are always interpreted as Dx by default even if the project is set to OpenGL.