Author Topic: Displacement not appearing in 3D View  (Read 756 times)

Displacement not appearing in 3D View- I've tried 'view output in 3d view' multiple time but it does nothing!

Hello,

Thank you for reaching out to us!

As a first step, please make sure your graph includes a 'Height' output, and that the information passed in it is other than 0 - i.e. not entirely 50% grey.
As you mentioned, you can also pass along Height information by right-clicking on a node, selecting 'View in 3D View' and selecting 'Height'.
Please note that matching normal information should accompany the height information, to ensure correct shading, as per the example below.



Then, we suggest checking that the 'Scale' parameter value in the 'Tessellation' shader 'Height' setting is higher than 0. This acts as a multiplier for the distance each vertex is moved.

You can find this parameter in the 'Materials > Edit' menu of the 3D View panel's top bar., as shown below.



Please get back to us with the results of following these steps.

Best regards,
Luca Giarrizzo
QA Analyst
Substance Designer Team