Author Topic: Normal map pixelated  (Read 2654 times)

Hey guys,

so I get a very pixelated normal map. Is this an expected behaviour or am I doing something wrong here?
I was just using a grunge map and plugged it into a normal node. Then I get this effect. I hope this wasn't asked before but I didn't find my particular problem on the forums. Changing the color depth to 16bit didn't help.

Greetings
monitorhero

Hey,
In your graph parameters, change the output format to 16 bits.

Hey Vincent,

as I wrote, I did change it to 16bit and it didn't help unfortunately.

Here is the file to explore it.

If you manage to get a result where there is no blocky, minecraft looking normal map I would be very grateful. Please help me out. Thanks a lot.

Greetings
monitorhero

The file you sent already has blur node but yeah. This is to be expected. Feeding a grunge directly into a normal will get messy. Best to blur it right after with a very low value; between 0.05 and 0.1

Actually the blur is just spreading the pixelation. and putting it after the normal generation it's not really getting rid of the effect. Just blurring the pixels a little but if you look closely you still see the individual blocks. I can't believe this is a normal behaviour. Haven't seen this in any video. The problem is that it becomes very apparent at 4k resolution.

Edit: Here is a screenshot of grunge map 010. The other pixelated one was 005. Maybe it depends on the map you use. Here you see on the black and white view it is pixelated, but the surface seems smooth once converted to a normal. With the grunge map 005 in the same input you  get the result from above.
Last Edit: August 12, 2017, 10:54:17 am

Hey,
For the squaring issue, it may be just because the 2d viewport zoom is not not at 100% (tell me if it works).
That said you can also use the Blur HQ grayscale for a better quality.
And finally, you should diminish the intensity of the blur: something around 0.03 should remove the artifacts without removing too much details.

Hey Vincent,

the pixelation at a high zoom level is common of course. But if you compare the two 3d views you see smooth transitions only in the second one. I think it is just a problem with this particular grunge map (005). I tried a few other ones and they all give you a smooth non-blocky surface ;)

I'm super late to the party but the bits per channel is the issue. If your normal node's bits per channel is set to either relative to parent or relative to input, check backwards down the link chain for a node that may be set to 8 bits. Making sure the "root" nodes channel is set to 16 bits will fix the pixelation. For instance, if you're feeding in a noise or clouds (or whatever) in which the output is 8 bit but feed that to a normal map, the noise/cloud node is the problem.

Good luck!

Have you tried Normal Sobel? That can give a smoother / cleaner normal map

Have you tried Normal Sobel? That can give a smoother / cleaner normal map

I know this thread is old but it didn't help solving my problem. In 256x256 it works out fine but as soon as I change to a higher resolution it breaks. Same problem with height map. See attached image. Maybe I set up something wrong?



Whenever I try get back into Substance Designer this issue throws me off.

I attached the sbs I just created for testing purposes.

Also when I set up the file with 16bit the individual nodes still say 8bit.

Another issue I have is when I enable tesselation the tesselated geometry doesn't cast any shadows onto itself. Is this normal behaviour? See second image



Could somebody upload a fixed version of the node setup? So I might understand whats wrong
Last Edit: September 28, 2019, 06:37:42 pm

So I tried the Substance Designer 2018 test version and the problem is not existing there. So I guess it's a problem of the older SD versions. Very disappointing. I guess this is a bug?



So I wasn't able to reproduce it in SD 2019.2.1.

For your second issue, you have to generate a normal map from your heightmap to get the proper behavior.

Thanks for the reply. By second issue you mean the missing shadows with tesselation?

Thanks for the reply. By second issue you mean the missing shadows with tesselation?

yes ;)