Author Topic: shaders issue - rendering diffuse as black  (Read 5695 times)

Hi guys thanks for getting back to me. I dropped the file parent resolution down to 128 with no luck. PBR works (even up to 2048x) but PBR_Gloss/spec doesn't work at all. I can't even tell what PBR's "supposed" to look like so even though that "works" maybe it doesn't? These problems are just way too confusing for me to try and figure out. I give up. I'll have to go back to using photoshop to make textures by hand. I might try using my windows laptop although again I cant tell if its working as expected. Way too much time wasted here. Cheers.

You haven't replied to those questions. Not sure you have seen them, so I'm asking again :
Are you sure you haven't accidentally switched off the point light sources ? Can you post your 3D scene settings (in "Scene->Edit...")? Also, can you try to add some ambient light and tell us if the diffuse texture appears ?

Sorry if this seems silly, but it really looks like the point lights are off.
Last Edit: September 30, 2014, 01:52:39 pm

I "reset all" and got myself a black cube. Upping the ambient makes the black grey, but theres no appearance of the red diffuse which is applied.

Sorry I went through all those suggestions with no luck. Theres ambient light, Light 0 and light 1 and bumping up the brightness of all doesnt bring out the diffuse colour.

Cheers

Heres the screenshots

Quote
I "reset all" and got myself a black cube. Upping the ambient makes the black grey, but theres no appearance of the red diffuse which is applied.

If you "reset all", all the texture slots in the 3D viewport are restored to the default colors (including the diffuse, which by default is grey), so you'll need to right-click again on your diffuse output and  choose "View in 3D view" for it to be used in the 3D view.

Let's be methodical. Can you please :
  • open the attached Substance
  • in the 3D view select "Scene->Reset Lights"
  • in the 3D view select "Materials->Default->Shader->Relief"
  • in the graph window right click on the graph background and select "view outputs in 3D view"

If the cube does not appear green, go to "Tools->Preferences->Editors..." and unselect "Post processes enabled" and tell us if the cube is still not green. If that does not work either, then we're probably facing an issue with the drivers which we are probably not going to be able to fix.

After a bit of googling, it seems that several applications have issue with the OSX 10.6.8 Nvidia 9400 drivers (Google chrome for example). Unfortunately with OSX, the only way to upgrade graphics drivers is to upgrade the OS, so I'm not sure that's an option you would consider.
Last Edit: October 01, 2014, 12:12:04 pm

Thanks for persisting with this but it looks like this is toast. I followed these steps with no success.

I'll have to revisit this in the future. I have Mountain Lion setup on an external drive somewhere that I never use so will dig it out, and see about installing the demo on there and reply here how I got on. I just have a whole suite of other pricey software that will die if I upgrade my core OS and/or hardware.

Thanks again, great to have some active support!

AaronC