Author Topic: MacOs B2M Problem  (Read 9826 times)

Hi, I use iMac for B2M Version 3.

Its Normal for changing Main Bitmap and Parameter on right side,

But, when i try to open Metalic Tab or Normal, its kick out.

Pls Help. Thank you.

Hello Allegorithmic,

I also have the same problem. When clicking any of those tabs, B2M crashes:
- Metallic
- Normal
- Height
- Ambiant occlusion

I've tried with both OpenGL and SSE2 engine and it crashes no matter what.

Could you please have a look at this? Right now, only Substance Painter seems to be usable on Mac.

Thank you.

P.S: I have a Mac Pro 2010, 12 cores 2,66 GHz with a GTX 780 and 64 GB of RAM, using macOS Sierra 10.12.3.

I've the exact same problem.
If I click any other tab than "Base Color" the program crashes and terminates.

My B2M was bought through Steam and is version 3.1.
How do I upgrade it to a newer version?
I can see newer version available in release notes.

I use an iMac 27" mid 2011 with El Capitain 10.11.6

same here...
Mac OS Sierra 10.12.6 Bitmap2material and Player every single time I click on metallic/normal/height/ambient it just crashes.

funny thing to point out is that it works fine on an external OS that is using 10.12.5, but this same OS I'm using right now(where the crashes happen) it used to be 10.12.5 and It was crashing anyway. I formatted everything hoping that will resolve but nothing.

I've included some files hope they are useful.

it works on Windows bootcamp for me.

MacBook Pro (mid 2014)
2.5 ghz intel core i7 16giga RAM
Nvidia GeForce 750M 2048mb

Last Edit: July 30, 2017, 01:11:24 am


I'm very sorry for this issue. I have reported this crash to the developers.

Head of Substance Demo Art Team
Twitter: The3DNinja


Same here with the Trial version.

I noticed that this was already reported in January but it's still an issue that makes this software unusable.

We are very sorry for these issues. Our team is investigating the problem. We are having difficulty internally reproducing this crash. I can't reproduce seem to reproduce it. There could be some hardware differences causing the issue.

Please let us know if you have AMD or Nvidia GPU?

Head of Substance Demo Art Team
Twitter: The3DNinja

Sure Wes, I'm running:

macOS Sierra
10.12.6 (16G29)

MacBook Pro (Retina, 15-inch, Late 2013)
- 2,3 GHz Intel Core i7
- 16 GB 1600 MHz DDR3
- NVIDIA GeForce GT 750M 2048 MB and Intel Iris Pro 1536 MB
- CUDA Driver Version: 8.0.90
- GPU Driver Version: 10.17.5 355.10.05.45f01

Hope that helps, thanks!

Sure Wes, I'm running:

macOS El Capitain

iMac 27" mid 2011
3.1 Ghz Intel Core i5
16gb Ram
AMD Radeon HD 6970m 1024mb

I got a new Macbook Pro 13" Touchbar yesterday.but havn't tried B2M on it yet, so I'll keep You updated.
3,1 GHz dual-core Intel Core i5-processor.
8 GB Ram
Intel Iris Plus Graphics 650
I'll keep You updated.

I am having the same issue.

I just purchased a license for this software and I cannot use it, since it's crashing every time I am clicking on any of those tabs.

macOS High Sierra

MacBook Pro 2017
3.1 GHz Intel Core 17
16 GB 2133 MHz LPDDR3

Radeon Pro 560 4 GB
Intel HD Graphics 630 1536 MB

Any help???

Here the crashlog.

Process:               player [80410]
Path:                  /Applications/
Identifier:            org.allegorithmic.bitmap2material
Version:               3.1.3 (3.1.3)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           player [80410]
User ID:               501

Date/Time:             2017-09-23 12:52:57.049 -0700
OS Version:            Mac OS X 10.13 (17A362a)
Report Version:        12
Bridge OS Version:     3.0 (14Y661)
Anonymous UUID:        64AC77F9-588A-984A-201F-F22EEFA9340B

Sleep/Wake UUID:       E82A016C-9677-4E4B-B446-9B23E0C69475

Time Awake Since Boot: 250000 seconds
Time Since Wake:       11000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler

VM Regions Near 0:
    __TEXT                 000000010f498000-000000010f894000 [ 4080K] r-x/rwx SM=COW  /Applications/

Thread 0 Crashed:: Dispatch queue:
0   org.qt-project.QtGui             0x00000001118a4413 QAccessibleEvent::uniqueId() const + 163
1   libqcocoa.dylib                  0x00000001144483e3 QCocoaAccessibility::notifyAccessibilityUpdate(QAccessibleEvent*) + 83
2   org.qt-project.QtWidgets         0x00000001112c32ba QTabBar::setCurrentIndex(int) + 362
3   org.qt-project.QtWidgets         0x00000001112c7836 QTabBar::mouseReleaseEvent(QMouseEvent*) + 694
4   org.qt-project.QtWidgets         0x00000001111680b8 QWidget::event(QEvent*) + 1656
5   org.qt-project.QtWidgets         0x00000001112c51d2 QTabBar::event(QEvent*) + 1074
6   org.qt-project.QtWidgets         0x0000000111128b76 QApplicationPrivate::notify_helper(QObject*, QEvent*) + 294
7   org.qt-project.QtWidgets         0x000000011112c1fd QApplication::notify(QObject*, QEvent*) + 9037
8   org.qt-project.QtCore            0x000000011223a3f4 QCoreApplication::notifyInternal2(QObject*, QEvent*) + 164
9   org.qt-project.QtWidgets         0x00000001111294f8 QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) + 968
10  org.qt-project.QtWidgets         0x000000011118964d QWidgetWindow::handleMouseEvent(QMouseEvent*) + 1325
11  org.qt-project.QtWidgets         0x000000011118878a QWidgetWindow::event(QEvent*) + 122
12  org.qt-project.QtWidgets         0x0000000111128b76 QApplicationPrivate::notify_helper(QObject*, QEvent*) + 294
13  org.qt-project.QtWidgets         0x000000011112b4c0 QApplication::notify(QObject*, QEvent*) + 5648
14  org.qt-project.QtCore            0x000000011223a3f4 QCoreApplication::notifyInternal2(QObject*, QEvent*) + 164
15  org.qt-project.QtGui             0x00000001118c49da QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) + 2794
16  org.qt-project.QtGui             0x00000001118addfb QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 155
17  libqcocoa.dylib                  0x0000000114436481 QCocoaEventDispatcherPrivate::postedEventsSourceCallback(void*) + 33
18         0x00007fff4e2ab6c1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
19         0x00007fff4e3652cc __CFRunLoopDoSource0 + 108
20         0x00007fff4e28e160 __CFRunLoopDoSources0 + 208
21         0x00007fff4e28d5dd __CFRunLoopRun + 1293
22         0x00007fff4e28ce43 CFRunLoopRunSpecific + 483
23              0x00007fff4d5ac866 RunCurrentEventLoopInMode + 286
24              0x00007fff4d5ac4df ReceiveNextEventCommon + 366
25              0x00007fff4d5ac354 _BlockUntilNextEventMatchingListInModeWithFilter + 64
26                 0x00007fff4b8aa44f _DPSNextEvent + 2085
27                 0x00007fff4c03f508 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 3044
28                 0x00007fff4b89f25d -[NSApplication run] + 764
29  libqcocoa.dylib                  0x000000011443537f QCocoaEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 2191
30  org.qt-project.QtCore            0x00000001122367a1 QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 401
31  org.qt-project.QtCore            0x000000011223aa65 QCoreApplication::exec() + 341
32  org.allegorithmic.bitmap2material   0x000000010f4b2bc7 0x10f498000 + 109511
33  org.allegorithmic.bitmap2material   0x000000010f49dba4 0x10f498000 + 23460
Last Edit: September 23, 2017, 09:53:56 pm

just upgraded to High Sierra and it seems to be working. both b2m and player

MacBook Pro (mid 2014)
2.5 ghz intel core i7 16giga RAM
Nvidia GeForce 750M 2048mb


Was anyone able to solve this? I get the same thing for B2M and Substance player. Clicking on any of the output tabs closes the application.

Changing the render engine does not resolve it.

I attempted to update to macOS High Sierra and it did not resolve the issue either.

iMac (Retina 5K, 27-inch, Late 2015)

4 GHz Intel Core i7

32 GB 1867 MHz DDR3

AMD Radeon R9 M395X 4 GB

===== New Session =====
Tue Oct 17 21:17:00 2017
[INFO][Translations] Search Paths:
[INFO][Translations] Use system locale
[INFO][Translations] Locale Found: en_AU
[INFO][Translations] Locale uiLanguages: en-AU
[INFO][Translations] Loading translation (substance, _, ) Failed
[INFO][Translations] Use system locale
[INFO][Translations] Locale Found: en_AU
[INFO][Translations] Locale uiLanguages: en-AU
[INFO][Translations] Loading translation (qt, _, ) Failed
[INFO][Translations] Use system locale
[WARNING][Default] (0): QMainWindow::saveState(): 'objectName' not set for QToolBar 0x604000252cc0 'Main'
[INFO][Environment] ApplicationInstallDir: /Applications/
[WARNING][SystemInfo] Fail to load news database (from file)
[INFO][Environment] UserDataDir: /Users/Zero/Documents/Allegorithmic/Bitmap2Material/3
[INFO][Environment] Settings:

[ERROR][GlProgram] Technique(Tesselation), ShaderType(Tessellation Control): Shader Compilation Failed
ERROR: 0:3: '' :  version '400' is not supported
ERROR: 0:3: '' : syntax error: #version
WARNING: 0:4: extension 'GL_ARB_tessellation_shader' is not supported
ERROR: 0:6: 'layout' : syntax error: syntax error

   ... (repeated 2 more times)
[INFO][Default] (0): QFileSystemWatcher: skipping native engine, using only polling engine
   ... (repeated 3 more times)
[INFO][Gui3D/Serializer]   Instancing Material (Key=default  Program=/Applications/
[INFO][Gui3D/Serializer]   Set material (Key=default Prog=/Applications/
[INFO][Default] (0): "Error transferring - server replied: Not Found"
[WARNING][SystemInfo] Fail to load news database (from https)
[WARNING][Default] (0): Cannot creat accessible child interface for object:  QTabBar(0x608000245130)  index:  3
Last Edit: October 18, 2017, 11:55:16 am

Me too Bought it today and realize it's not working as expected. Having same issue, crash when switch to other tabs.

Hi all,

I reproduce the same crash with the same callstack after enabling Dwell Control.
For those who have this option enable, please try to disable it (in accessibility options) then launch B2M /Player and test it.
Does it solve your issue ?

Thanks !
Last Edit: November 27, 2017, 04:41:35 pm
QA Analyst