Author Topic: Substance not rendering and undeletable  (Read 3760 times)


hope I'm right here with my post:
I'm experiencing problems when I use a Substance in a Houdini Scene and want to delete the shop node. Houdini is simply crashing. And also when I want to render the substance material. Mantra is simply saying that it's missing a shader and renders the material in simple grey.

I have the newest versions of Houdini, Substance Designer and the plugin

Any clue or did I miss something?

Regards, Alex

Hey alex_47,

What version of Houdini, Substance Designer, and plugin are you using specifically?

As I said, the current ones:

Hey alex_47,

Was just making sure I had the same versions in order to reproduce your issue. Using 16.0.557, I was able to reproduce the crash and will enter it into our bug tracker. Thank you for taking the time to report this!

As far as the rendering is concerned, can you post a picture of the errors you are getting?

Hey Keston,

thanks for the quick reply! Here's a pic of the described errors:

Hey alex_47,

Ahh I see. This is a known issue with our plugin and Houdini (and assigning the substance at an obj level). If you assign the substance using a material node then the substance will render correctly. The shopnet includes a substance node with the substance loaded into it. The shop is then assigned via the material node. You may also have to click the blue button on the material node to set the render/display flags. I also used a uvtexture node and set the texture type to 'face'.

Hope this helps!  :)

Hey Keston,

thanks for the quick solution for the render issue. I tried it and it worked well :)

Hey alex_47,

That is great to hear! If you have any further questions, please don't hesitate to ask. ;D