Author Topic: .sbsar wont publish in designer 6  (Read 2592 times)

I posted this in another thread, just re-posting it here.

Hi there I am getting a similar issue, however my error list is not as long as the previous one. im trying to create an .sbsar however i get this error every time i try to publish. 

I am not sure what i causing this issue, however i was able to publish a less complicated graph (it didn't have materials dragged into it, or sub graphs) im not sure if there is something wrong with my work flow or this is just an error or bug. also in all graphs i try to publish i get a warning when selecting compression size that i have a node that is not pixel size is not relevant to parent (i previously had nodes that were uniform color so i set them to 32x32 pixel size however i have since reset all nodes to relative to parent and this warning still persists)

Would be grateful for any help with this.  :D

Hi Neil,

Can you send me your sbs ?
It would be easier to help you if I can test your sbs :)

Thanks !
QA Analyst

iv  joined it to this, if you need it sent another way just say

that's perfect !
I will test it and keep you inform.
QA Analyst

that's perfect !
I will test it and keep you inform.

Hi there, any luck with finding out what is causing this problem??

Hi ,

Sorry for the late answer. Yes I found something and I succeed to publish.
I just set all the subgraphs and the main graph in relative to parent x1 instead of absolute.

But two graphs were missing in the dependencies : pebbled which has exposed parameters and Equirectangular.sbsar. I used place holders instead.

So double click in the background of your graphs and change the output size to relative to parentx1 (256 x 256), try to publish and tell me if it works.
If you still have the same issue, right click on your package, choose the option 'export with dependencies' -> build the archive and send me the archive. :) 
QA Analyst

Hi there still getting issues with publishing these graphs, it is only .sbs files that have sub graphs and dependency as a few of my other substances have published with no issues. I have attached a folder with the two substances that have this issue, and have built the archive for them, I don't know if I am getting this issue because i am using instances of other packages i have open or if its because i am using .sbsar that i have dropped in from my desktop before opening them.

Also when i load these files it looks for a file called iv looked on my pc and i cant find this file on my computer anywhere, and SD asks me to provide a new location (im not sure if this is related to my publishing issues but is something that only occurs with these files that wont publish.

The second file that is having the same issue.

Hi Neil,

After lot of tests on 6.0.0 and lot of fail with error 6, I tried to run tests on 6.0.2 and it works !

In 6.0.1, we fixed an issue with the cooker but the error generated was an error 13.
I think you had the same error 13 but in one of your subgraph and it generated an error 6 when publishing all your graphs.
So update your Designer to 6.0.1 or 6.0.2 and you shouldn't have issues ! :)
QA Analyst

Thank you ever so much for all you help with this just updating now so will know soon if it works.

i have one more question that isn't related to this, but i have taken some other .SBSAR files (which i managed to publish) into marmoset tool bag 2 and 3, I have followed the set up for Substance in marmoset however they will not display as a material, they also give me none of the extra settings that should be available in the bottom tab once you select substance.

 i was wondering if i am missing something in the set up of my materials when i published them, or if marmoset doesnt yet support files from SD6? (i have managed to make it work with an SBSAR from substance share, I do not know if this was made on SD5 or SD6 though).