Author Topic: Empty baked maps  (Read 5629 times)

Substance Painter 2 bakes has been failing and creating empty normal maps on every model I try to bake. They do not end up black like others posts but grey.

I went back and downloaded previous versions of SP until the bakes worked again (would be really nice to see release date + change logs on download page). Basically, since version 2.5.0+ I am unable to bake .obj, .fbx, anything. Version 2.4.1 works perfectly for the same meshes. Thank God it works so I can get some work done. Baking is a pretty critical component in the 3d texturing pipeline especially for software like this, right?

Log attached from failed bake.

High / low meshes in .obj and .fbx on Drive:

I'm happy I can go back to 2.4.1 and get some work done but it seems like this has been an issue for the last 3 releases. Please help!

Bumping. I hope you can help me Allegorithmic! I'd love to use 2.5 features. Thanks!

We are looking into it.

Great! Thank you

Bumping again. I installed 2.6.0. Same issue as 2.5.x releases.

I opened a project that baked perfectly in 2.4.1, rebaked in 2.6.0 I get an empty normal map. I have to downgrade to 2.4.1 again to get any work done. Please help! Thanks

I am getting perfect bakes with your meshes (fbx) and the default settings in 2.6 here.
The obj bake is showing some issues on polygon seams but no black bake.

I don't believe there is anything wrong with the meshes (which is why it bakes perfectly in Painter 2.4.x as well as latest Designer).

Something changed in 2.5.x which breaks bakes on my machine. I sent you the specs and the logs. Is there anything you can extract from that? Latest OS X Sierra, Titan X and updated Nvidia drivers.

I'm sure I could hop on my Windows machine and bake it out just fine, but that's not the system I use for development.

Just a quick note, maps aren't baked out as black images. They are totally empty. Grey (matching the background).

I'm at a loss for words Allegorithmic. It's now July. I've been bugging you since April 7. I've tried forum posts. I've tired direct messages to Jeremie.  I have yet to bake a single normal map since Substance Painter 2.4.1. I just tried 2.6.1. No go. I can't continue to use 2.4.1 forever.

Completely different 3d model. Same failed bake results. I am on a Mac with latest Sierra, latest Nvidia drivers for Titan X. Please tell me what I need to get to you to finally figure out how to resolve baking issues. You say it's working on your computer, GREAT! That means the model files for low + high are more than likely 100% fine! But it's not working on my computer which is the one really matters to me. Please, you guys. I've been a paying customer for years. I want to do the most basic of tasks when it comes to substance which is also one of the most important. Bake maps.

Screen shots:
1) Prior to bake.png - shows screen shot of me opening my .ssp file from Painter 2.4.1
2) After bake.png - shows after baking.

Here is link for low (AllUV_low.fb) + high (Ticker_high.fbx) models + log files from Painter.

Quick update:

I popped in an AMD Radeon HD 7950 into my 2012 Mac Pro tower to see if it made any difference because simply tapping "Activate Post Effects" turned the render view black (didn't used to) and baking now WORKS.

Obviously there is something wrong with Sierra + Nvidia Titan X + Substance Painter.

It's not exactly convenient to have to swap video cards just to use one piece of software but it's better than not not being able to update Substance Painter or not being able to bake at all.

Please, review compatibility with Titan X + Sierra + Substance Painter. There is definitely something seriously wrong with Substance Painter > 2.4.1

Hey Matt, glad you got it working even though as you said, it's not ideal...
Mac workstations with Kepler GPUs are a pretty rare occurence and we don't have this setup internally which makes it hard to figure out what is going on. We'll look into it more closely as soon as we can get that setup together.

I recently updated my Mac to the latest OS (Sierra) using NVIDIA GeForce GTX 1070 and have the exact same issues with baking. Even the black screen when activating post effects. After reading this post I downloaded Painter 2.4.1 and everything works fine.

I don't have the luxury of changing the graphics card though and, I too, don't want to use 2.4.1 forever. Is there any other solution to this issue?

Same Same. I posted recently about it. I booted into windows to bake and then saved out the project and re-opend in macOS to continue working with it. Only real reason I had to update the OS was Painter stopped supporting iRay on 10.10.5 so i upgraded the OS and now painter bakes don't work

same setup with Titan X card in mac pro 5,1. It's the only software that currently doesn't work properly (that Ive discovered since the OS update 3 months back)

Same thing with Substance Painter 2017.2
I'm on Sierra with NVIDIA GeForce GTX 1050 Ti 4095 MB.

I'm bumping this back up. First, I don't think Mac Pros with Nvidia cards are that rare, not for people working with 3D and Substance apps, and secondly, why not just reintroduce the old baking system from v2.4.x? All it does is make maps, right? If that system worked on all Macs back in October of last year (!) why not just reuse it for the time being?

Bump up again, lol.

Are you seriously? I can understand when such things appear in earlier releases. It's already the end of 2017, but you can't (or don't want to) solve this problem. If your software isn't able to function correctly on Mac, then just do not release it  >:(

When will this problem be solved?

iMac (27-inch, Late 2012), NVIDIA GeForce GTX 675MX 1 GB