Author Topic: Fresh install hangs on update check?  (Read 2889 times)


I have a licensed version of Substance Painter. On version 05.0333 I seem to get a hang and implicit crash while it has the "check for new version dialogue" up. It had been working fine on the windows PC (win8) earlier today.

I had initially purchased the app through Steam. Was frustrated about the steam check-in process so uninstalled  from steam and re-installed it via Allegorithmic site. All fine.

Installed local license. No probs.

Started to import local HDRs for custom lookdev ens adn linked local dir of B+W bit maps for alphas in shelf dir in "My Docs" area.

Then hangs stared happening repeatedly. Pop up window states "(not Responding)". Main app window has "checking for new version..." in lower right corner with red box.

Regressed all changes (removed lookdev exrs, license file, alpha shortcut, fresh install). Still hangs. Haven't gone back to steam install yet.

Not sure what to try next?



I moved back one release version and seem to be able to get the app up and running again. seems to work for me but continues to hang/freeze at start up. The "It's beta software" window still pops up but is unclickable.


Mine was freezing too; launching it once with the 'run as administrator' option fixed it though.


Oh yeah, Duh. I'll give that a shot. Ha. :)


Tried a fresh install and the 'run as administrator' option. Same hang at the same point as before.

Still no joy. :(

Hopefully a fix (for whatever is going on) in next release. I'm back on the old version for now.

Thanks for the bug report.