Author Topic: 2.5.3 Baking AO from LP with normalmap is broken.  (Read 2377 times)

Hi, yesterday i ran into problem with baking AO from lowpoly with normalmap on steam version of SP.
I specially made test case and it happens 100% despite of what mesh and settings are used.
It seems like the horizontally flipped alpha(empty uv spaces) is removing ambient occlusion from texture which is utterly weird. The problem doesn't exist while baking without normalmap.
I am attaching images with problem (AO is strenghtened so it is more visible). Also i circled the broken parts and corresponding empty uv's parts. I am attaching link to a sample scene.

Note that it is a simple mesh without any uvs issues like overlaps out of 0...1 space or flipped faces.
I hope for a quick fix because it kind of stops my work.


https://www.dropbox.com/s/puifilnp7qbw52i/ptr.spp?dl=0

Last Edit: March 17, 2017, 11:26:02 am

Hey thanks for the feedback: I am reporting this to the QA team.

When the fix can be expected ?

looping @Damien Climent who will be able to investigate a bit more.

Any news?

Hey, sorry for the late answer: in the AO baker settings, uncheck "ignore backface"

It doesn't change anything. You can check it in the project i attached.

I did and it changed for me

Here is a video walkthrough:

We are investigating the issue on our side, it seems there is a bug somewhere in the bakers.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Here is a video walkthrough:


Oh, i was changing ingnore backfaces in common options - my bad. Changing it in AO options helps a little but the bugs are still visible, even in your video.

We are investigating the issue on our side, it seems there is a bug somewhere in the bakers.

I hope it is going to be a quick fix.

Thank you guys for helping :)

I downloaded  painter 1.7.3 and made comparison with 2.5.3 with the same mesh and normalmap, everything bakes fine in painter1.
Also note better behaviour on the seams in painter1.

Any progress? Any estimates? It has been almost a month.

the next update should be there is less than 2 weeks.

Hi , the update to 2.6.0 fixed the issue of blank parts, BUT: The baking result is now completely wrong so it is still useless, it looks like some blended channels from normalmap instead of proper AO.
I attach the screenshot with comparison to painter 1.7.3 where it bakes properly.