Author Topic: Hard UV Seams, Even with Triplanar projection turned on  (Read 15466 times)

From my experience, "hiding" seams using materials + triplanar usually works. BUT as soon as you use (procedual)masks, aka dust, dirt, grime, you name it - the noises will generate seams at UV islands - so you will notice seams, no matter if you use tri-planar or not. :(

I wish, there was a way to avoid this somehow - you can not allways hide seams, like on object-parts that got most of surfaces visible...

Sure - you can just "clone-stamp" and try to paint over seams by hand, but it´s time consuming. Or if you can use a material without a mask-fx, you should be fine.
Last Edit: June 07, 2017, 10:17:53 am

I'm looking at the circled area (in Reply #5), and it looks like there is a lot of stretching on the right side of the seam.  That makes me suspect you have an issue with the "texel density" in that area.

Just from looking at your mesh, I don't see anything obvious, but it's hard to tell from these screen shots.

AN EXPERIMENT:
> Paint a "large dot" (in the 3D view) that crosses that seam
> Inspect the 2D view...
> If one half of the dot covers lots of pixels, but the other half only covers far fewer pixels, then that is a large portion of the problem.  Fixing that might not eliminate the seam, but it will improve things considerably.

SEE THIS POSThttps://forum.allegorithmic.com/index.php/topic,17467.0.html
His picture looks similar to yours, and I have a link to a great tutorial in my reply there.
He was able to fix his problem.

Good luck.
Last Edit: June 07, 2017, 02:41:34 pm
Hobbyist
----------
Common "Help" suggestions:
- LOG FILE tips - https://forum.allegorithmic.com/index.php/topic,22451.0.html
- LICENSING issues https://www.allegorithmic.com/contact
- ATTACH files and pictures to posts: https://forum.allegorithmic.com/index.php/topic,23670.0.html

I find workarounds for it, but not resolutions.

One of the more difficult things to deal with is the Generators in Painter, some of which do show up the seams quite badly.  The resolution there is knowing you're going to use the generators, and plan the seams accordingly.

...so still there is no real solution to work with the generators without visible UV seams? O.O That scares me a bit...

Using triplanar mapping on your grunge maps in generators should get rid of pretty much all the seams, then if the seams come from an uneven texel ratio, that's on the artist to fix his UVs. If you still have seams in some places, you can add a paint effect in your mask stack and paint over them.

That's a relief :) but why do I keep on getting UV seams in my normal maps (and in curvature as a result)...? Texel ratio is even within each texture set/material, uv's are not flipped or overlapped. Baking in SP, with HP mesh, followed step by step your instruction from YT: "Model Preparation 03: Tangents & shading for Normal maps" (exporting w/o tang&bin, in SP: DirectX and Compute Tangent ON). As per Maya's 2018 exporting issues I triangulated beforehand and exported with Smoothing Groups (which is only one - the model is organic). High poly mesh is from Zbrush so I aligned FBX file format for exporting to version 2016/2017. 16px padding/dilation for 2k... and here seams appear :D Triplanar helps just a weeeeeeee bit. I spent a very romantic evening with my computer yesterday rummaging through the Lands of Internets and trying out many options and variations of the above options but without much luck. Please tell me it's just some rookie mistake and I forgot about sth crazy simple and obvious :)

Could you post screenshots of the seams you are seeing and the meshes used if possible?

Oh, sure sure sure, I should've done that at the beginning :)

Seams on normal:



Low poly from maya:



High poly also from maya:


Initial version of high poly from zbrush:



I was trying different version of HP meshes to see where the problem is hiding (too much divergence maybe... No idea, I'm green :D ) - but the results were basically always the same :)

A seam on the normal map doesn't mean anything and could be completely normal depending on your UVs, how does the model look in material mode?

That's what I was hoping for - so I wasn't worried until I saw that tri-planar is not helping with removing these seams :)

Random material with tri-planar projection ON:


Uniformed base color (looks exactly the same with and w/o tri-planar):


Dirt generator (tri-planar on a base fill and on generator itself):




Little rascals are also visible on renders :)

Hello,
though this topic seems to be quite unattended for a couple of time, I just want to throw my problem with UV seams in here, as it seems to fit.

As a beginner I went through the "Getting started..." with Painter and Designer Tutorials and now I want to try it with my own models. But now I run into the same problems with UV seams and the curvature map (maybe another map as well, which I just haven't noticed yet).

The seams on my model are clearly visible as I try to create a black mask with the mask editor and the usage of the curvature map:



Things I have tried so far:
1. Using tri-planar projection (works for the fill layers but not within the mask editor).
2. Baking the curvature map with different settings. Even enabling or disabling the seams does not have any effect. I still get these artifacts on the seams.


3. Trying the algorithm per pixel and vertex, but pixel is still the better result:


4. At least I tried to paint the artifacts away, but nope: No painting on the curvature map possible
5. Tried to export it to pdf, to overpaint it in another program. Clever move Adobe, only export function to Photoshop possible, but I am using Affinity.  :(

Finally here is a picture of the UV Layout. Of course I could stitch the UVs all together but for a better texel density I decided to cut the larger parts. So until now I am struggling to find a balance between UV-space-efficiency - amount of seams - requirements for painter.



So any advice or pointing in the right direction is much appreciated.

I've had the same issue right now and I've solved it going into the Texture Set Settings tab and switching "Normal mixing" from "Combine" to "Replace"

It worked for me, I hope it can be useful for someone else too