Author Topic: issues with the 3d view while trying to blend height maps in Designer.  (Read 999 times)

i've just finished this tutorial : https://academy.substance3d.com/courses/Creating-your-first-Substance-material

it looks great, and exports well with/without the water level value enabled-
UNTIL i try adding noise to the water level' heightmap so the water looks more realistic. (i.e not flat.)

one attachment shows my node setup near the outputs for the substance, another is the 3d/2d view for the output of the substance. (https://i.imgur.com/9Zfuu82.png), (https://i.imgur.com/kAA1wHq.jpg)

the 3rd attachment is how the setup shows up in Blender's Cycles engine. i'm not focused on the broken roughness as that's my own fault, i'm focused on how the noise for the water shows up in the Blender render but not the 3d view in Substance Designer. (the noise also shows up in Blender's own material/non raytraced view, which is analogous to the 3d view in Substance.) (https://i.imgur.com/r22cHpH.jpg)

if i have a setting wrong or if i'm just not doing this right, please let me know what i'm doing wrong :)

EDIT: will not let me upload attachments so i will use imgur links.
Last Edit: December 30, 2019, 11:59:12 pm

i hadn't been aware that you HAD to have a working normal map alongside your heightmap when working in the 3d view. this was not made clear in the tutorial, however it might have been in some other one i haven't started yet.