Author Topic: Substance Designer crashes when creating a new substance  (Read 4087 times)


I've tried running SD 5 (Windows version which crashes when trying to create a new substance. I've installed all previous versions and they all do the same thing. I've re-installed 5_3_4_build_17162 which previously worked but now crashes when creating a new substance, although I did update my Nvidia driver when trying to get the latest version to work. So now I've had to go back to using SD 4.

My PC specs are:
Window professional 7 (service Pack1)
Intel Core i7 CPU 920 @ 2.67 GHz
GeForce GTX 650 (Driver version 375.70)

I can't export the log file as SD 5 just crashes and shuts down. Unless there's another way of retrieving the log file?


This just started to happen to us this morning. Same exact issue, same hardware, same troubleshooting steps. Any ideas yet?
Last Edit: November 16, 2016, 08:36:00 pm

No ideas yet I'm afraid and no help yet from Allegorithmic support :(

Hi guys, sorry for the delay.

I investigate about your issue, and could you try to delete the folder "Substance Designer"
Here: HKEY_CURRENT_USER\SOFTWARE\Allegorithmic\Substance Designer

To do this you must use "Registry Editor"
To run it, type "regedt32" in the Windows Search tool

Best Regards,
QA Analyst and Technical Artist at Allegorithmic

Thanks so much Damien, but unfortunately the issue still persists. Did it without rebooting the machine, did it with rebooting the machine. Did it with a uninstall, then fresh install, same issue comes up. So weird, the product has been working great up until 2 days ago...

@rwazejewski I see that your Drivers wasn't up to date, also can you try to disable the PostProcess in your preferences.
Is the crashes happens too, when you load an sbs file ?
Last Edit: November 18, 2016, 04:15:05 pm
QA Analyst and Technical Artist at Allegorithmic

@help_5 Please can you try to disable the PostProcess in your Preferences
QA Analyst and Technical Artist at Allegorithmic

Thanks for the help Damien! Just wanted to post that I did try this, but with no luck. The prob is still persisting...    Larry


Just want to say I was having the same issue with a brand new install.  Disabled Post Processing and now it works fine.  Thank you!

disabling post process solved both file open/create new project crashes
will there be a proper fix for this so we dont have to turn off postprocessing?

@pacsuta.david Of course we will work on this crashes, but this is a very tricky issue because Yebis doesn't crash with all Graphic Cards.
Last Edit: November 22, 2016, 03:14:12 pm
QA Analyst and Technical Artist at Allegorithmic

Hi Damien,

thanks for the info. I'll attach a dxdiag report and post my specs here to help with the investigation although my gfx card is quite old and may not be relevant to provide a fix for it:

Nvidia GTX460 v2 1GB (Manufactured by Gigabyte)
Driver version: 314.22 (Indeed this is a very old driver but Nvidia never fixed their drivers for my graphics card and anything newer than 314.22 causes constant system crashes, so driver update is not an option for me)

While my gfx card does not meet the minimum requirements for Substance Designer, I just want to say that I had no issues in the past up until and including SD 5.4

Hey David,
Thanks for these Infos about your hardware setup.
About your issue with the Post Effects (Yebis) i just checked on our change log and in between SD 5.4 and 5.5 we have upgraded to Yebis 3, this is the reason of your troubles.
QA Analyst and Technical Artist at Allegorithmic

Thanks for clearing that up. I'm going to buy a new PC in January and I guess I'll just use SD5.4 until then