Author Topic: Been having trouble importing files like FBX to OBJ  (Read 5310 times)

Recently I have been having problems opening file formats in substance painter 2 and I am not sure if its a bug or something that the company haven't patched yet, any thoughts?

maybe you can attach one of your files to see if the problem is  only on your machine!!! ::) ::) ::)

it has been happening to my fellow co-workers too, but the program does work if it is on a older version of substance painter.

Hey Zachary - when you say "trouble opening" - what is actually happening? Does it import but it's jacked up? Do you get an error message? I'm sure Allegorithmic could use a log file generated after one of these failed imports.,3063.0.html

And like PixelUVW mentioned attaching one of the files in question would help as well. I have not had any issues with importing any mesh formats personally.


the program is updated and so is the GPU but it seems to fail to open the file. It won't even show the mesh when I try to open the file.

you should give more info, as what program did you use to export meshes, which options you have activated, which fbx version you exported to, etc.

Maybe you export curves or modifiers in the mesh and substance does not handle very good? maybe I'm wrong but its a possibility.

Maybe your mesh have too small dimensions?
Maybe you are importing a highpoly mesh with 10million polygons?
are you sure your mesh has uvs assigned?
have you tried to rename files to eliminate spaces? I always use camelCase names.

The first three of your questions for me is that I made the models myself and they are low poly from 500 to 5,000 maybe polies, I UV them properly and even color code them to help with texturing, and the dimensions are a fair size on the uv map because they make up the space in the uv map. The only thing that I haven't tried was changing the file to where there is no spaces on some of the files although the majority of them is only a one word file.

I don't like spaces in the paths either, but not sure that would cause an issue. Just for grins try exporting to your desktop with no spaces and then try to import that FBX. Keep the path simple.

Failing that I would say to attach or upload one of the problematic files here and attach a log file so that Allegorithmic can take a look.,3063.0.html

What program are you exporting from?

Maya 2017 and I got it working so thanks for the help guys.

Do you know what was causing the problem? I bet it was a curve or modifier not applied  :P

Maya 2017 and I got it working so thanks for the help guys.

Please share the solution - it could help someone else down the line. :)