Author Topic: Set Default Baker File Format in SD5  (Read 2294 times)

Is there any way to change the default baker file output format from SVG to a different file format (like png)? I understand that you can use the drop-down box to change this setting each time you bake, but this is kind of a pain. I'm looking to set the output format once and it stay permanently.

Thanks in advance (even if the response is for me to create a thread in the feature request section).

Screenshot attached for clarification.

Normally the file format should be set to the last selected. It should not reset to svg. Don't you have this behaviour on your side ?
Product Manager - Allegorithmic

Nicolas,

Sorry for the late response, but I just now noticed that you replied.

I think the output format used to stay on the last-selected at some point in time, but that may have been in SD4 days, and I'm honestly not sure. With my current updated version of SD5, the baker outputs reset to SVG format every single time, even if I go back and do a re-bake within the same session.

Sometimes I forget to change them to png and don't notice until I import the materials to UE4 and see some interesting blocky artifacted normals.

Here is a gif of it in action. Hopefully you can read the text without having to squint too hard.


The "convert uv to svg" baker can only output a svg file.
Do the other bakers in the list also outputs svg?
Product Manager - Allegorithmic

Yes, file outputs for all the other bakers also default back to SVG.

OK, it's probably a bug. I think that if you set the format to png for this baker it should work (I mean the uv to svg baker)
Product Manager - Allegorithmic

Your earlier question just helped me figure out the issue. If you delete the "convert UV to SVG" baker from the list, then the default output format stays selected as png. Apparently just having a "convert UV to SVG" node in the list, even if it isn't checked as being used, will default everything back to SVG output format every time.

I rarely use that baker, so I'll delete it from the list and I think my problem will be solved. Thanks, Nicolas.