Author Topic: Substance Painter 2.4.0 Export textures are black.  (Read 18094 times)

Hello all,
I'm new to the forums here, but I was hoping you guys could help me out with something.  When I try to export my textures, they're exporting black.  I just updated to 2.4.0 today (Steam), and I also had to update my GPU drivers.  I believe the texture exporting worked fine with a previous build.  I just wanted to check in with the forums to see if this is a known issue, and if there's maybe something I'm doing wrong, before I submit any sort of formal bug report (if this doesn't suffice as a bug report).  AO and DirectX normals seem to be exporting fine, but all other textures (ambient occlusion [i.e. crevice], diffuse, glossiness, and metallic) are coming out black.

FWIW, I have a GTX1080.

Thanks!  Let me know if any further info is needed.
-Chris
Last Edit: October 28, 2016, 03:59:50 am

Please provide some screenshots and details about your project and export configuration.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I've attached a few screenshots.  The first few are the solo'd textures in Painter (what I'm expecting to see exported).  I've also attached my export settings, and a folder view of the exported textures in thumbnail form (they look the same when opened in Photoshop; there's a few extra textures in there as well).

(Excuse the textures at the moment; this is just for testing purposes at this time)

Does it work if you use an alternative padding setting ? (Like padding infinite)
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Yes!  That did the trick!

Thank you!

I'm having the same problem with textures exporting black after upgrading to 2.4  -  Padding settings have no effect. Doesn't matter what export settings I use.   
NOTE: Seems to have something to do with a smart material that I made in the previous version...
Last Edit: October 31, 2016, 07:19:28 pm

We are currently investigating the issue.

@yonderbean Please attach your log file.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Same .. all textures black with 2.3.1

log;

Quote
[Scene 3D] 3D scene successfully loaded
[Plugins] Loading plugin photoshop-export
[GPUIssuesCheck] The current TDR (GPU hang recovery) delay is low: 2s.
   Substance Painter can be interrupted by the OS when doing a long computation.
   See https://support.allegorithmic.com/documentation/display/SPDOC/GPU+drivers+crash+with+long+computations
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[GenericMaterial] Creation of the shader pbr-metal-rough successful
[GenericMaterial] Creation of the shader pbr-metal-rough successful
[MapExporterDialog] Starting map export
[MapExporterDialog] Map export ended
[MapExporterDialog] Starting map export
[MapExporterDialog] Map export ended
[MapExporterDialog] Starting map export
[MapExporterDialog] Map export ended

padding infinite

regArts
Dee

@dennis.dworak Please attach your log file too.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Same problem here with Substance Painter 2.4 (latest release). During baking, an error message appears (see attachment). Then when I build up the material for the asset, everything first seems to be normal in the preview, the materials show fine in the preview. Also I can add and pick base textures to and from the new designed shelf. But when exporting the final textures, some of them turn out black like described by the OP (Metal Roughness workflow, especially Base Color, not sure about others)

What I tried so far:
- run SP as administrator... no effect
- try other paddings.... no effect
- try other export settings and resolutions for export... no effect


Edited: Obviously I had made a mistake when trying out different dilation settings. Indeed the export of textures works, if I chose a setting different from 'No padding, passthrough'. Sorry for that. What happens, if I chose a different width for the padding during baking than during exporting? Do I need to memorize what setting for the padding I had entered during baking, so I can match the same width during export? Or will the settings for export automatically adjust the pre-baked textures?
Last Edit: November 04, 2016, 01:25:18 pm

Sorry, i just changed our export presets .. and it seems that the old presets from 2.4. had to be touched and now it works...
i cant reproduce the failure :(

The funny thing is despite the error message 'baking failed' (see screenshot in my previous post) the baking seems to work, at least as far as I can see. I can then create materials on this object and export them and they seem okay, not sure about the height and normal features though, because my current surfaces are flat.

What does the funny 'can't find vertex colors' in this error message mean?
Last Edit: November 08, 2016, 02:14:12 pm

The error message is pretty clear : if you tried to bake the ID map with the "vertex colors" setting enable, while the mesh don't have vertex colors, it will fail.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thank you Froyok. I will try to figure this out.

Is this some default setting which has changed since the previous version? Because I have never touched any settings (especially not for baking ID maps), and this error message never happened in the previous version of Substance Painter?

I don't think we changed anything, but maybe the code of our baker was updated. I will check that with the developers.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.