Author Topic: Substance Plugin 0.3.2 Released (UE4.1.0 Compatible)  (Read 9901 times)

The Substance Plugin V0.3.2 is now live here: https://github.com/Allegorithmic/UnrealEngine

This release is compatible with the Unreal Engine 4.1.0 release

Why does this come as a 404 error when i click the link even if I am logged in?

Why does this come as a 404 error when i click the link even if I am logged in?

Hello Foundre69!

Make sure you are logged into github with the user account that has access to the UE4 repository. Our repository visibility depends on your account having access to the Epic repository as well.

Well now that was painful...so it appears that I have 2 github accounts and I was logged into the wrong one...  Apologies and thank you.

Well now that was painful...so it appears that I have 2 github accounts and I was logged into the wrong one...  Apologies and thank you.

I'm NOT alone! Foundre69 I had the exact same experience and cause yesterday :)

No problem! I'm glad it was easily resolved :)

I am getting an error when using your new version of substance with the enw version of Coherent UI. https://forums.coherent-labs.com/index.php/topic,291.0.html

I am getting an error when using your new version of substance with the enw version of Coherent UI. https://forums.coherent-labs.com/index.php/topic,291.0.html

Hello Fsalabedhabt,

I have sent an email to Coherent Labs to see what can be done to resolve this issue together. Thanks for bringing it to our attention!

Coherent Labs provided an update on their website regarding the plugin issue, but to re-iterate here:

If you have an existing Unreal Project (*.uproject) and want to use Substance with it, you must make sure the plugin is enabled in your project files. Go to your project folder, then within there path to Saved/Config/Windows/Engine.ini in a text editor. When you load that file, find the [Plugins] section and make sure in that section is a line EnabledPlugins=Substance .

You don't need to do this if you make a new project with the Substance branch of UE4 as new projects automatically enable the plugins it came with.

As quick feedback with this release;

UE crashes when;
1. set all outputs on of one substance
2. copy the substancegraph then try to disable one of the outputs of that copy= it crash instantly

I hope you guys add the ability to set outputs on a desired texture channel (example; put heightmap in normalmap alpha channel). The powerful UE material editor could leverage this ability to a large extend.

Please allow us to go up to 4K output size.

Also I was wondering, the UE4 substance build is 12GB large Oo, can we do something to reduce the footprint?

There are issues with undo when changing substance parameters (it undo sometimes previous engine modifications instead)

It seems the substance property tweaking window can't dock like other windows.

I would like to be able to have a look at the texture (by double clicking on the texture in the content browser for example like normal textures).

Other than that it seems it working ok, I've had a couple crashes though I don't remember how they happened.

Good job and thanks ^^
Last Edit: May 09, 2014, 03:55:10 pm

Hi bigzer,

Thanks for bringing these to our attention, I've made sure we have visibility on these issues.

On the issue of 4K Output size, this is not used at this time for performance reasons. If 4K is very important for an asset such as skyboxes or macro detail, you can export the maps in Designer and import as regular textures in UE4.

As for the build size, the vast majority of that 12GB is going to be the Unreal Engine itself. The Substance Plugin is only a few megabytes of that total. You could reduce the footprint by selectively removing plugins (as an example if you don't use source control, no need for P4/Subversion plugins), but we want to stay as close to the UE4 release builds so it's easier to users, so we will provide a build that matches what Epic releases.


Is it compatible with 4.1.1? I just copied the substance plugin and recompiled, then I got many erros when i tried to enable via window plugins. Why do we have to run through such nightmares whenever an engine update comes. Please make it BY DEFAULT for the engine and the problem will be sloved. Thanks.
Last Edit: May 13, 2014, 01:17:04 am

ew


Hey guys,

I noticed that in order to access the Substance plugin repo you need access to Epic's UE4 rocket build. Is there any option to get this plugin for UE4 licensees that aren't accessing UE4 through GitHub?

I'm also Hoping to get a working 4.1.1 with substances (it fixes an annoying shader compilation bug).

Concerning the GitHub build, there's no other solution at this moment. I hope eventually to get a standalone plugin or to get it fully implemented in main builds. I'm pretty sure the later will eventually happen, it all depends on how fast Allegorithmic can get a stable version working before they can negotiate pulls.

In the meantime we're left with the current cumbersome solution but that's better than nothing!

Regards

Hello. When can we see this pluging for UE4 4.2?
4.2 has some great new components and I'm waiting for an upgrade on this plugin to try it out. I've bought maaanyyy substances for Unity and would like to try them on UE4 as well.