Author Topic: Iray Rendering Incorrectly  (Read 4205 times)

Hey everyone!

Loving the new Iray feature but I can't seem to get it working probably.

I'm doing a few quick models of a French Adrian helmet from WW1 and I've textured it how I want on Substance Painter but when I go over to render it in Iray it seems to slice up the helmet and only renders a few areas of it.

Helmet in painting mode - http://imgur.com/Agcf1SM
Helmet in Iray Render mode - http://imgur.com/zYUFTjX

From above it looks as though there are some constraints stopping certain areas from rendering - http://imgur.com/TJ2g6IU


Any ideas on what the problem is?

Cheers!
Last Edit: September 23, 2016, 04:34:44 pm

Do you have an opacity channel in your document (in one of your texture set) ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Not sure what was causing it. No opacity channel either.

I ended up just re-exporting the .fbx file, created a new project in SP, then the helmet rendered correctly.


Actually, the problems seems to be coming back again. This time I'm trying to do a pistol, and it just cuts it in half.

There's definitely no opacity set or anything.

Please attach a mesh file that would allow us to reproduce the issue. :)
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Attached :) It seems that when I rotate the mesh within Iray the whole thing sometimes shows but then is cut again when rotated at certain angles.

Thanks for the file, I reproduced the issue and logged it in our database.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thanks!

Any ideas on what's causing the problem?

One of my friend faced same issue. I was able to find solution, thanks to the workflow in substance painter. I saved the layers to smart material and loaded the fbx agin in new file and assigned the saved smart material to it. And that worked. Hope this helps you too.

Had this exact same problem, any definite answers?

Had this exact same problem, any definite answers?
With the recent updates of Iray on our side we didn't encounter the issue again.
If you still get the problem with the latest version of Substance Painter then I would like to get a mesh to reproduce it if possible.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I've got the same problem, I have no opacity at all.
It look like there is a plane that cut the mesh if we come too close to the camera (like it is the camera that cut the mesh due a colision), I tried to move the ground X,Y and Z, play with the camera settings as well, deactivate the ground, put in infinite sphere, change the viewport resolution, etc I do not see what i didn't tried yet in SP.
About my mesh I have it exported on 0,0,0 in Maya.
It is not the firts time that I have this issue but it is the first one that is really problematic.
Luca Eliseo
Environment artist looking for a job.