Author Topic: Way to pack outputs into channels?  (Read 5263 times)

Hello, I was wondering if anyone found a way to pack the outputs into an RGBA texture like what is done usually when not using a sbsar in UE4. I've tried using a RGBA merge node and setting it to an extra output, but the problem I'm having is that it doesn't seem to output the alpha. The texture has an alpha in UE4, but it's just blank white.

Hey,
The darker your alpha will be, and the more it will occlude you texture (making it transparent) therefore if your alpha is full white, you won't any transparency.

here is my solution, just created a new node :]

and I also created a custom UE4 graph template for all my substances, with some basic parameters already exposed so it saves me a lot of time :]
Last Edit: September 21, 2016, 02:50:35 pm

Hey,
The darker your alpha will be, and the more it will occlude you texture (making it transparent) therefore if your alpha is full white, you won't any transparency.

If I'm understanding you correctly, you are thinking I have a full white image as the alpha input? If so, then no that's not what I'm doing. I put just a normal pattern like you did in the screenshot. But the problem is when I export the sbsar into Unreal, the texture it outputs for the RGBA merge, (the AO_R_M_H_Packed Output in my screenshot), shows that it has an alpha, so the alpha is there, but it doesn't match what I put into the Alpha input of the RGBA merge in Substance Designer. Instead it just shows all white.

here is my solution, just created a new node :]

and I also created a custom UE4 graph template for all my substances, with some basic parameters already exposed so it saves me a lot of time :]

Cool!. I'll look over those screenshots and see If I can create something similar. Thanks. :D

EDIT: make sure output node supports the bit depth range to store an alpha channel :]

my solution doesn't work.  for some reason the substance plugin ticks the option "compress without alpha" by default and it can't be overridden ??
any solution for this?
I pack my rough, metallic, AO and height into 1 texture to reduce memory and also texture samplers in shaders, this is kind of important to have

Last Edit: September 28, 2016, 04:11:48 pm

EDIT: make sure output node supports the bit depth range to store an alpha channel :]

my solution doesn't work.  for some reason the substance plugin ticks the option "compress without alpha" by default and it can't be overridden ??
any solution for this?
I pack my rough, metallic, AO and height into 1 texture to reduce memory and also texture samplers in shaders, this is kind of important to have

Hi,

I'll have the devs look into the Compress Without Alpha option being locked. How did you get it to work with the Outputs in Designer?

Cheers,
WEs
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

EDIT: make sure output node supports the bit depth range to store an alpha channel :]

my solution doesn't work.  for some reason the substance plugin ticks the option "compress without alpha" by default and it can't be overridden ??
any solution for this?
I pack my rough, metallic, AO and height into 1 texture to reduce memory and also texture samplers in shaders, this is kind of important to have

Hi,

I'll have the devs look into the Compress Without Alpha option being locked. How did you get it to work with the Outputs in Designer?

Cheers,
WEs

It seems to work fine, I just had to click on the output node and manually set it to 32bits from default which is probably 8bits?