Author Topic: 2.3 Export Normal doesn't include Additional Maps  (Read 4558 times)

Hi!
Since we updated to 2.3 we are having issues with exported normals not including what is in the additional maps (baked normals), only what is in the height channels.
We export to Converted maps Normal DirectX.
We reverted to 2.2 and it works fine.
Last Edit: September 19, 2016, 03:42:03 pm

Can you show an example ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I have the same problem.
The exported normal maps are just the height channel converted, without combining the "input mesh data" normal map.

Please provide more information :
- log file (see https://support.allegorithmic.com/documentation/display/SPDOC/Exporting+the+log+file )
- images
- texture set settings
- export settings
- and so on...
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Same thing here. When exporting Document channels + Normal + AO (No Alpha) I only get the painted details in the normal map, instead of combined (baked + painted details).
I can only get the baked map with additional maps export, all my projects have the same problem.

Log here if it helps: https://drive.google.com/open?id=0B1R3U18B2YMMcEFfZU8wWVN0d1U

Which export preset are you using ? Is that a custom one ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Document channels + normal + AO, I thought that was the default one? The first one on the list, the one i've always been using. I haven't made any custom presets.

On a simple project I'm not able to reproduce the problem. The normal exported combine all the channels without any issues on my side.

Are you able to reproduce the problem on any projects ?
Can you describe a bit more how your project is setup ?
What are your export settings (all of them) ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Hey!
We have had 5 different people in different projects have the same issue.
The project is setup from an imported FBX and TGAs and custom template.
We tried a bunch of different exports, but our default is Specular, Diffuse, Glossiness & Normal DirextX.

It would be great if you could provide a example project to reproduce the issue.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

From the sample projects, FireHydrant doesn't export painted details, but PreviewSphere does...
Last Edit: October 04, 2016, 07:09:41 pm

The FireHydrant project use the Material Layering shader, which only has mask (opacity channels) in the layer stack. The height/normal data comes fomr materials which are not exported. See this page for more information : https://support.allegorithmic.com/documentation/display/SPDOC/Dynamic+Material+Layering
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

That was my ignorance then, thought it had something to do with this.

But. I made a test project in 1.7.3, opened it in 2.3 and saved. Then exported the normal map from both versions with same settings, and now it's the other way around. 2.3 exports painted details but not baked. Exporting works fine if i create the project from scratch in 2.3.

I made a terrible picture: https://drive.google.com/open?id=0B1R3U18B2YMMYWtXYzJWQjcxM1k

Also, why is the quality so much lower?
Last Edit: October 05, 2016, 06:08:00 pm

Can you send me the project ? I will look into the export issue more easily this way.

As for the "quality" that you mention, it's actually subjective. Since Substance Painter 2 we a new algorithm to convert the height into a normal map which has a much better quality, but with results that are less sharp sometimes. In some case you can get the feel you lose details, but in some other especially with smooth gradient you get a much better quality. It's a trade-off. A good workaround is to work directly with normal maps.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Having exactly the same issue.

Just to clarify:
My project consists of a low poly prop, I have added a baked normal map (TGA) from 3DS Max with all the details from my High Poly in it. It looks perfect in the Substance Painter viewport. Then I paint some more height details on it in SP. Again, everything is fine.

However, when I go to export all the textures using the default settings as I have been since I started using SP, the normal map is missing all of the details from my baked normal TGA. It only exports the height details I painted in SP just as in Restors picture.