Author Topic: Long time for creation of thumbnails, what to do?  (Read 7957 times)

I assume I'm doing something wrong with organizing my shelves.
The issue is, that it takes up to 5 minutes for Substance Painter (2.3) to create all the thumbnails for my materials. So when I start Substance Painter, there is a time span of about 5 minutes where I need to wait for all my materials showing in the shelf. Funny enough, at the bottom of my screen Substance Painter shows 2 or sometimes even four message bars telling 'Generating thumbnail(s)...' and showing the red 'busy' light there.

I found some people in the forums having problems caused by 'Openshot Video Software', but in my case I don't have this software installed on my Desktop, so the reason must be different.

I am able to work in the meantime, but can never be sure to have all my materials already shown in the shelves. The messages sometimes don't even disappear after half an hour of Substance Painter running.

I must confess that I have around 248 smart materials in my shelf, plus the other tabs for normal materials, smart masks, generators, textures, alpha maps, and so on. So I assume that I simply do something the wrong way with organizing my material presets. Obviously I shouldn't keep them all in the shelves, but instead do some different organization?

It would be great if we could keep materials outside Substance Painter, organized in meaningful folders, and probably screening them with some 'viewer' tool, to decide which and what I need to add to my shelf for this specific project?

Also it could be helpful if Substance Painter wouldn't create all thumbnails from scratch over and over again when the application is started afresh. Instead it could save the thumbnails in the shelves, like most 3D applications do, so it just needs to load the existing thumbnails and create only thumbnails for new materials where the thumbnail is missing?

What am I doing wrong here?
Last Edit: September 16, 2016, 09:15:00 pm

Since 2.3, thumbnails have a lower priority  in comparison of the main 3D viewport.
Did you try waiting for the shelf to load without opening a project ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I made a test run using a stopwatch, just starting Substance Painter 2.3 then doing nothing apart from looking in shelf tabs to check loaded materials. It took 7 min 20 sec to fully include all materials in the shelves.

It seems like it is basically the smart materials, while other shelves are being filled immediately after opening them.

I attach this log file and dxdiag here.
Thank you very much for looking into this.
Last Edit: September 19, 2016, 01:41:13 pm

Was it already that slow to load the shelf in the past ? Or is that a recent behavior ? Did you get this issue in older versions ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

In my perception it was not this slow before. I never before saw these red buttons ('Creating thumbnail's...' message at bottom of screen), but maybe they were introduced in SP2.3?
Since updating to v 2.3 I added like 10 or so smart materials to the shelf, so I don't assume this could explain the increase.

I saw many warning messages in the log file telling 'this and that ressource not found' and such. This surprises me, because after filling the shelves the materials work like expected. And it appears to me as if all materials are finally seen in the shelves, none of those which I added seems to be missing...

I checked the smart material shelf for those ressources not found' materials, and I found like 5 materials which seemed to be installed in the wrong place. According to their suffixes I removed them from the smart materials shelf and pasted them to the ordinary material shelf.

After this, I cannot find 'ressource missing' messages in the log file anymore. However I could not notice a speeding up in the filling of the shelf.

Could attach an updated log file then ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Sorry I forgot this.
Startup time (until completion of creating all thumbnails) was 7 minutes this time.

From your log file, I see that the default shelf is longest one to load. Exactly 324034ms (arround 5min) for your shelf "C:/Users/Charlie/Documents/Substance Painter 2/shelf". There is also still warning message regarding some metadata not being saved.

Can you try the following ?
1 - Reinstall Substance Painter
2 - Reinstall the Shelf : https://support.allegorithmic.com/documentation/display/SPDOC/Shelf+is+empty
3 - (Only if 1 + 2 doesn't work) Move your "My Documents" folder on an other hard drive (for testing). See : https://support.microsoft.com/en-us/kb/253682
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Okay I'm in the process of doing these. Re-Installation didn't change anything.

But when planning to deleting the Allegorithmic shelf according to your instructions, I noticed, that under Documents/  I have TWO subfolders, one named

'Substance Painter'    (containing 'plugins', 'samples' and 'shelf' subfolders), and the other named
'Substance Painter 2' (containing 'export', 'plugins', 'samples' and 'shelf' subfolders).

Is this normal? Both of them contain an 'Allegorithmic' subfolder under the 'shelf' folder, so I'm puzzled about which one to delete according to your instructions?

I also noted, that creating the shelf thumbnails starts with materials from my Mood Pack (Military Soldier), and this goes really slow. So I tried re-installing the Mood Pack, but it still didn't speed up things. So I'm waiting for your reply about the two parallel 'Substance Painter' and 'Substance Painter 2' folders, where to delete what.
Last Edit: September 21, 2016, 01:48:01 pm

I've moved all of my library and substance install folder to an SSD drive - recommend it to everyone!

'Substance Painter'    (containing 'plugins', 'samples' and 'shelf' subfolders), and the other named
'Substance Painter 2' (containing 'export', 'plugins', 'samples' and 'shelf' subfolders).

Is this normal? Both of them contain an 'Allegorithmic' subfolder under the 'shelf' folder, so I'm puzzled about which one to delete according to your instructions?

The Substance Painter folder is the shelf from Substance Painter 1.x, you can delete it if you don't have custom content you want to keep in there.
It will not affect Substance Painter 2.

I did delete the folder 'Allegorithmic' in the user/documents/Substance Painter/shelf  directory.
After this, I started Substance Painter. The delay time until the log window reported 'All thumbnails have been created' was again around 6 to 7 minutes.
I copied the log file (attached here as 'log20160921-2305.txt'). All smart materials have shown up, it didn't seem there was something missing.

Then I started Substance Painter a second time, and again the delay time for startup until completion of all thumbnails was 7 minutes 20 seconds.
I also copied this second log file and attached it here (log20160921-2315.txt'). Even when the completion of creation of all thumbnails was reported in the log window, still a red light warning with the message 'Creating thumbnail(s)' remained at the bottom of the GUI, and it never extinguished.

I checked the folder where I had deleted the 'allegorithmic' folder (almost 1 GB in size). The folder 'allegorithmic' has not been recreated there, it is now just missing there.

I am worried about messing around with the 'My Documents' folder. It holds 52.2 GB of data, contains 141,867 files.
As I can't oversee the consequences for other programs I am using, I really don't want to touch it. There may be license files or whatever, and I have a large number of various programs installed on my machine, including Python programming environment, dozens of programs which I depend on every day...

If you deleted the folder "allegorithmic" in "Substance Painter/shelf" and not "Substance Painter 2/shelf, it will have not effect. Can you retry ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.