Author Topic: Substance Painter scale bug.  (Read 6445 times)

I was following a lesson video, apparently I noticed the paint brush size is different. Like 10-11 times difference as seen in the video compare to mine. Even though I followed the whole scale as shown in the video. The app tool is Blender.

What I kept trying to do is:

Press Export -> select FBX format -> tick "Apply Transform"

Still doesn't work. I do even tick "Selected Object" at above "Apply Transform" tick. Tried tick "Custom Properties" below the "Apply Transform" doesn't work either.


Could show a screenshot of the interface with the issues and the brush parameters visible ?
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

What you mean by brush parameter visible? I followed the same as the video size, it says brush 5 size, mine has to be size 50-55 to match the video's size.

Plus, I checked many times on my blender's scale with the video's scale when initiated the box polygonal modelling. We both have same scale size and dimension in Blender. Something wrong with Substance Painter maybe?

I'm talking about the interface of Substance Painter.
When you are painting on your mesh, the tool properties should show with the brush parameters (size, flow and so on).
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

My apologise for the ignorance. Here is the brush parameters: -

So... today I did try on getting Ctrl + A -> select "Scale" (to make it all X, Y, Z: 1, 1, 1 scale. Still doesn't work. Anybody please?

Or Substance Painter isn't meant for Blender afterall?

Substance Painter works fine for Blender.

The scale problem is the way the FBX exporter interprets Blender units.  One Blender Unit is typically assumed to be 1 m.  Other programs assume 1 unit is 1 cm.  The exporter needs to be set to account for the units that you use.  There are several ways to change the scale in the exporter.

Try unchecking the little button to the right of the Scale number in the Blender export panel (with Scale =1.0).   If that does not solve the problem, change the scale value itself.

You don't need the Experimental Apply Transform or the Export Custom Properties either.
Last Edit: August 29, 2016, 03:20:54 pm

So, what value should I change?

I followed thoroughly on the video shown, including the Ctrl + A for Scale (to scale X, Y and Z to all 1.0). Are you saying everyone's Blender size after porting to Substance Painter is different now?

Clearly, it's a bug. I did all the test try and error for unchecking/checking each option, including uncheck/check all the options you mentioned. Same thing.

In the Blender FBX export panel there is a Scale parameter input.  To the RIGHT of it there is a tiny button.  It is a toggle.  Your picture shows that it is on.  Try turning it off then export selection only again.

There are many posts about Blender and FBX scale mismatches with other programs.  Most can be solved by changing the scale value in the export panel or resizing the model inside blender.

You could also try exporting .obj format, but FBX works fine for me.

I am seriously lost. For days I am stuck with this alone, Google-ing doesn't help either.

Okay, what I did was follow your instructions: Go to Export FBX page -> Hit that grey colour toggle tiny button(it turns white colour as in it's off, right?) -> hit "Export FBX" button on the top right. It does not work still.

I do wish to export as FBX format though. Also, if I am to change the model size, it won't make sense anymore because mine is going different from the tutorial video's size.

I would like to apologise for the bother and nuts. This is really nonsense to me now.

No problem.  Sorry my suggestions have not worked.  Would you please post a link to the tutorial so I can try and duplicate the brush size issue?

Not your fault. I am already thankful someone answered(not sure where @Froyok the admin went to).

Thanks.  I watched the video and will reproduce it in the morning.  I noticed a couple of interesting things though.  First, someone in the YouTube comments mentioned the brush scale discrepancy.  Was that you?

Second, he creates the radius of the barrel at 0.610 Blender Units but calls it "point six one centimeters".  Of course, this is an absurd size but makes me wonder if he has changed the scene scale from the default value.

I will test.

I think I've got it now.

The brush size is a fraction of the size of all of the objects that are in the scene.  (When the size space is set to "Object").

When I exported only the barrel, I replicated the problem you saw.  When exporting the barrel and much larger floor and walls into Painter, I found that when working on the barrel, the brush size corresponded to the ones shown in the tutorial.

So were you only exporting the barrel and not the other objects in the tutorial scene?

Just to clarify the export settings in Blender:
- 7.4 Binary
- Selected objects checked (make sure you have selected the objects in your scene)
- Scale = 1.0
- Scale all data according to blender size: Enabled  (this is the little button with left-right arrows)
- Forward: -Z forward
- Up: Y up
- Export: Mesh
- No experimental or custom
- Path mode: Auto
- Batch mode: Off

Omg. Now only I get to use PC to test out Blender, sorry for the late reply, I saw your message but cannot test out to reply.

That way, it solves the issues. I wonder why? Blender bug or what? Again, sorry and thanks.