Author Topic: Disable Substance on Dedicated Server?  (Read 2596 times)

Our dedicated server is generating substance textures on startup, and from what I can see in debugging is also eating memory. Ideally the substance plugin should be completely disabled for the server, as the textures and materials should be irrelevant to anything the server does.

Is there a simple change I can make to the plugin to disable it when running a server?

Hi stefan3iii,

I have added this to JIRA so we can get this fixed for you and others with this problem.

Great thanks, can you reply to this post when a fix is in? I'd like to preport it into our engine.

Absolutely! I have added this thread to the JIRA ticket so we'll know to update it.

Hi, is there any progress on this issue? If it's not being actively worked on I'd like to know, because we'll need to address it ourselves, the problem is becoming more urgent for us.

If an Allegorithmic engineer could point us in the right direction (ie best place to start looking in code) that would be helpful too.

Hi, is there any progress on this issue? If it's not being actively worked on I'd like to know, because we'll need to address it ourselves, the problem is becoming more urgent for us.

If an Allegorithmic engineer could point us in the right direction (ie best place to start looking in code) that would be helpful too.


Hi,

Which version of the plugin are you using?

Speaking with the devs, it will be a fix within the new update. As for the running on the server there is a task in the works to not include the plugin or disable it when the dedicated server configuration is set.

Cheers,
Wes

Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

We're using
"Version" : 39,
"VersionName" : "4.12.0.15",

according to Substance.uplugin

I've brute forced this for now, by just preventing the plugin from ticking on the server. That mostly disables it and prevents the textures from being generated at least. But a more complete disable would definitely be appreciated. Thanks for the update :)