Author Topic: Huge compression issues with sbsar to UE4  (Read 4211 times)

So I'm having some pretty big problems with importing SBSAR files into UE4 in regards to compression. I've changed every setting I can think, I followed tutorials on importing substances into UE4 and nothing is working. The albedo and normal map both have extreme compression artifacts and I'm not sure what to do now. The texture resolution is at 2048x2048 and it still looks like that in editor/in game. I can assure you that it does not look like that in Designer.




I've attached the sbsar in case someone else wants to give it a go.
Last Edit: July 09, 2016, 12:18:58 am

Same thing here...

Yeah, this is a pretty big problem. It's doing this with every sbsar I import into UE4. I'm having to export the maps as bitmaps to UE (kind of defeats the purpose of the Substance plugin) and change the compression to a vectordisplacement map just so the textures look right.

Does the artifacting problem go away or change if you change the engine from CPU/GPU to the Editor settings (Reboot is required)?

Nope, that was one of the first things I tried. For now, I seem to have figured out the issue: I have to set my albedo & normal outputs to absolute 8 bit right before the end of the chain. Once I do that and import the sbsar, the compression is gone.

Ahh, interesting.

What the format before? 16bit? Would you be able to send the first version (SBS) (with the artifacts) to josh.coyne@allegorithmic.com? I feel that either way this is a bug and should be fixed in the plugin.
Last Edit: July 12, 2016, 05:16:14 pm

I had same problem and was able to fix it by setting the format of normal map output node to RGBA (32b) intead of default within the Substance Designer   :) :) :)

Couldn't upload the image, so I've twitted it for you: https://twitter.com/eVG_lf/status/764574900686323712

Hello Guys,

we also ran into the problem.
i can't confirm what eugen.lofing77 said.

but what you maybe did and what it fixed fore me was set "USE TRIPLANAR" to False  on your node(s).
I had this just on 1 material on a mesh and yeah this fixed it.

can someone confirm this?
Last Edit: March 03, 2017, 03:09:21 am

Hello Guys,

we also ran into the problem.
i can't confirm what eugen.lofing77 said.

but what you maybe did and what it fixed fore me was set "USE TRIPLANAR" to False  on your node(s).
I had this just on 1 material on a mesh and yeah this fixed it.

can someone confirm this?

Hi,

The triplanar node requires the data to be processed in 16bit or you will get artifacts. You need to use the Substance GPU engine for this to work. You may have UE4 plugin set to use the CPU engine.

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

bullseye! yeah its on cpu. Going to talk with my programmer tomorrow. What would you recommend on the fly?
cause its not that super important now for us to use triplanar mapping. we close to be done with our project and it looks good enough for our amount of people anyway.
Last Edit: April 25, 2017, 02:25:22 am