Author Topic: Slow 3D painting tool  (Read 14479 times)

Hi, everyone,

I evaluate Substance Painter Trail for test if I like it or not before I arrange purchasing online soon. I have some problem with 3D painting Tool issues. I notice painting tool is slow and stiff when I painted texture, stencil, colors, and etc on mesh but some of tool are fast and smooth. I don't feel like a natural feeling painting there. It keep saying " Computation in Progress " below that distracts me when I painted on it. I have my Nvidia Quardo FX 4800 with GPU that should work fine with SP but why slow painting?  I tried to add SP in the list of 3D application in my video card to fix it but not working. I have no problem with my Mudbox that has fast and smooth painting tool unlike SP.

Take a look at two image below

Anyone, do you have any suggestion or idea how to fix it if possible?

Thanks

drakemoonstar

Nobody reply any comment here ? it's so quiet here.

I bought Painter last night online after I evaluated with for few days and uninstalled Trail. I would learn how to use 3D Painting tools to create textures on mesh and exporting texture maps to 3D models that would be useful for the animation production and my personal artwork.

I'm thinking if it would be good idea for me to unintall old driver file 170.51 and download new driver file to upgrade my Quardo video card through Nvidia website that possibly fix painting tool to do better peformance and stability. I use 170.51 for long time that is good compitablity to run smooth with Maya for using model and animation in viewport and Mudbox for painting and sculpting. Whether I would download new driver to fix it, it would be no good and troubleshooting to mess up my both Maya and Mudbox that worries me. I'm not confident yet if I would try testing it to solve it. If not good, I would be sad to roll back to older driver. New 1.0 Version would upgrade Painter to improve better soon this around April so I will wait for it to solve my Painting tool issues if possible.

if you have same issues with your Quardo or Geforce video card to run with your painter and Unity, 3D studio max, Blender or whatever, let me know anytime for feedback to solve whatever to better improve Painter.

Thanks

drakemoonstar


Hi,

We indeed recommend to use the latest drivers available. The painting should be really quick and smooth, you shouldn't get the "Computation in progress" message.
Did you try to paint/visualize a single channel? You can switch it in the "Viewers settings". You can as well change the quality of the PBR shader, and that may help to paint faster.

Cheers,
Nicolas
Head of Product Management

I have that same problem.. And my graphic card is firepro... For zbrush user - my pc can withheld up to 16 million polygon in single sub-tool.. Make the math..

I have that same problem.. And my graphic card is firepro... For zbrush user - my pc can withheld up to 16 million polygon in single sub-tool.. Make the math..

This is not a question of polygon, but shader.
You should play with the viewers quality setting to adapt it to your card. High Quality and Very High Quality are slow, but medium Quality should run find on most of the computers. Let me know how it goes.

We are anyway currently making a big work to optimise shaders, so it should run much better in the next builds.
Last Edit: April 09, 2014, 09:37:06 am
Head of Product Management

Here a Ent I am made.. getting using with substance painter.... ( aye I've brought it.)

Before I return to this painter.. at this very point where I cannot painting add on anymore until I close painter and restart computer then return to painter to carry on..


While I painting on the model using wood stencil...
this what happen to my desktop..


If I am painting too fast and it just "Computation in progress" and it is jamming for over 4 hour... have to close task using task manger.


My pc are window 8.1 64 bit, ATI firepro V7900 with 16GB RAM, Intel Core i7-3820. 3.60 GHz

Look forward to next build. :)

I did uninstall old driver: 270.51 ( not 150.51) and downloaded new driver: 332.76 from Nvidia website to install my Quardo video card. I tested Painter again. I notice painting is a bit faster but don't see really big improved performance and smooth much better. Sometimes older driver work better and new driver doesn't work better for some reasons so it depends on what kind of video card with GPU are compitable with softwares. Compulation in Progress " is still there when slow painting continue again. Paint material is still slower than other tools. I tested combine Brush ( Artistic 1 ) and Painter ( gold ) on Cybrog's metal arm that are still slow.  Brush ( Artistic 1 ) and Stencil material ( stitch ) are fast paining when Computation in progress is one sec each time. When I see it again and again, I press ESC to stop. I felt up and down with those conflict paintng tool.  I'm waiting for next new build to upgrade it to run fast and smooth soon.

My OS system is: Window 7 Pro 64 bit, 16 GB Ram, Intel(R) Core(TM) i7 CPU 860 2.80 GHz and Nvidia Quardo FX 4800.

Drakemoonstar
Hi,

We indeed recommend to use the latest drivers available. The painting should be really quick and smooth, you shouldn't get the "Computation in progress" message.
Did you try to paint/visualize a single channel? You can switch it in the "Viewers settings". You can as well change the quality of the PBR shader, and that may help to paint faster.

Cheers,
Nicolas

Did you try to change the quality in the viewer settings?

Nico
Head of Product Management

For drakemoonstar? Wait for his answer...

For my? You can see it in screen shot.

Did you try to change the quality in the viewer settings?

Nico

Hi Nic,

Yes I did try changing quality in the viewer settings. I examined and tested everything there. Low, Middle or High quality are better choice for smooth painting. I still have problem with Painter Material and Stencil tool doesn't work properly ( rolate and zoom when using paint texture on mesh ). They need to be fixed.  I suggest you to remove Compulation in Progress from Painter for next new build to update it soon.

I made video clip at YouTube to show clearly what exactly I described some of problem painting tool issues. Please watch at https://www.youtube.com/watch?v=fu0Wcki-JVo&feature=youtu.be

drakemoonstar

Here a Ent I am made.. getting using with substance painter.... ( aye I've brought it.)

Before I return to this painter.. at this very point where I cannot painting add on anymore until I close painter and restart computer then return to painter to carry on..


While I painting on the model using wood stencil...
this what happen to my desktop..


If I am painting too fast and it just "Computation in progress" and it is jamming for over 4 hour... have to close task using task manger.


My pc are window 8.1 64 bit, ATI firepro V7900 with 16GB RAM, Intel Core i7-3820. 3.60 GHz

Look forward to next build. :)

Hi Daniel,

I have seen your description with two screenshot. I understand about your problem painting issues. I have two problem Paint Material and Stencil tool which I'm not happy with.  Don't worry, it will fix in next new version of SP for sure.

Did you turn off Aero Theme in your desktop? It could helps painting tool going fast and smooth.

drakemoonstar

Oh my god! Your are worse than mine... I have no problem with gold and copper in my desktop.... It don't slow down just yet..
Maybe that because I use very large brush and stroke all over this cyclone..

Hmm... Let me thinking.. Everytime I painting using wood stencil or material, undo sack up a list and it just keeping sacking.. More undo list = more computer lag on those heavy substance material.

Reason : every time I paint it and save it then restart it.. It go back to normal until you stroke more paint on it for undo list.

To see if my theory are correct...
You can try it yourself to see if it can get better after clear off the undo list.

I downloaded 0.4.0.303 Version of SP to fix Paint Material and Stencil tool in my desktop. You guys should get it now from your account to download it. It's better than old 0.3.0.285. I use stencil tool to smoothly rolate and zoom texture map when I paint it on mesh without problem. Paint Material ( gold, copper, coblat, etc ) improve better and fast. I pressed [ and ] to change the size of brush painting to test speed with them. I don't have any problem with the small and medium size of brush painting that can paint fast on the mesh but the big size turn on and off slow and fast like 1-3 second each time so not bad. The version of SP Beta is still work in progress until the next build will be new to upgrade it so I hope it would handle the big size of brush painting to run better performance without " compluation in progress "  so I better wait for it soon.

I just downloaded the beta today so I am assuming it is the latest version. I find it impossible to use because of how chuggy the painting is. I set the quality to low (like others have done), and even if the brush is small..it still gives me "computation in progress."  It doesn't matter if it is in solo view or panorama.

I will see if it is better with newer video drivers, but I doubt that is the main culprit here. I run a number of other 2D or 3D packages without any trouble.

Hi,

What are your specs?
Also, how does it run in mono channel instead of PBR in the viewer?\][po876

Cheers,
Nicolas
Head of Product Management