Author Topic: Image Input  (Read 2445 times)

Hi,

another Unity related question: I created a simple test graph, using three input images:



then I publish the subsar file and drag and drop it into Unity Project window.
From there I assign the substance and assign maps to the image inputs:



as far as I can see, the generated diffuse map is ok, the spec is assigned as Diffuse´s Alpha, but the normal map changes.

here is a screenshot of the map, that I input into the substance:



and here is the generated texture:



It´s not about the image ratio, but most of the normal map detail disappears

I am sure this is a simple issue, sorry for the long post ;)

PS: I wonder how to post images in this forum, that are resized/displayed properly... one scrollbar for the whole post is quite unhandy
Last Edit: March 25, 2014, 03:11:44 pm

When you use a Substance in Unity, if the output is a normal map (checked with the "Usage" of the output node), the integration will automatically shuffle the channels to fit with your project settings.
If you generate your normal in Substance Designer, you'll get the same result in Unity.

But if you use a bitmap, it will be modified if you process it into a Substance. To avoid this, here are the main steps:
- In your Substance, switch the Y channel (green) of your normal input using a level filter (cf screenshot attached).
- In Unity, in your normal bitmap properties, be sure the "Texture Type" is set on "Texture" (and not "Normal map").
Then you should have the same result.
Last Edit: March 25, 2014, 05:38:58 pm
Lead technical artist
gaetan.lassagne@allegorithmic.com

Thanks a lot, that really helped!

now with the correct normal map behaviour, the paint wear also behaves as expected!

SOLVED